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Introduction
 
Mastering Excel is one of the most important decisions you can make to take your career to the
next level.
But, learning Excel can be tricky at times, as the software allows you almost infinite possibilities,
so navigating it could feel a bit overwhelming. That’s why it’s crucial for you to lay down solid
foundations from the start, master the basics and learn how to use advanced strategies to reach
your goals.
Hi, my name is Robert King, I am an entrepreneur and I have been a passionate Excel user since
2014. My background is in Industrial Engineering and Management Science. I have and lived in
Italy and I graduated at the University of Kent with a final dissertation on linear regression
techniques applied to predict growth on a set of SMEs. But I am not a statistician! My
background is in business. I have been working in Digital Project Management for most of my
professional career, I have also acquired a lot of experience in Digital Marketing and Online
Advertising and I have been using Excel almost every day at work for a variety of tasks, such as
data analytics, client reporting and presentation, automation building, Visual Basic
Programming, CRM management and more.
Over time, I have started to love Excel and found out I could use it even to design mock-ups, to
log my activities, keep track of my expenses and, in a few words, to organize my life. 
I basically have a spreadsheet for everything, including, grocery list, with weekly and monthly
quantities, prices, meal plans! I started learning Excel at the workplace, with my boss teaching
me a few basic commands I needed to know for the sake of my job. But I quickly realized I had
to become very proactive and start learning on my own and that has not always been easy.
Sometimes. I felt I was lacking some foundations and I couldn’t really progress as I wanted.
Over the years, I have also combined Excel with other passions of mine, book & blog writing
and software development to make Excel even faster. I love building automation to simplify
people’s life and save them a ton of time and I also enjoy the education space, as I love to
breakdown simple concepts into bite-sized chunks that are easy to digest and assimilate.
And this is exactly how I wrote this book. This book is going to be a journey into Excel most
used functions, formulas, features and much more. You will learn how to use Excel and become
a pro, whether you need it for work or personal use, you will learn why learning Excel is
crucial for business, the job opportunities you can have with high-level Excel skills, and
practical examples of what you can do with Excel. This Essential Guide has everything you need
to know to consider yourself an Excel Pro.
It is designed with an engineering approach to give you solid foundations from the start, covering



shortcuts, hacks, tips and tricks and much more! Moving on to Excel best practices, expert tips
and advanced strategies to take your Excel knowledge to the next level. You will be able to
understand the most important features and how to leverage them to create automations. You
will discover advanced methodologies and small details breakdown but also the big picture and
the whys.
✏   NOTE: Sometimes you will have to fill in the gaps! I inserted a lot of illustrations and step-
by-step processes, but I also want you to open Excel and follow the examples by replicating
them.
Only then, you will be able to learn. Sometimes I could have spent 2/3 pages more talking about
one formula, the syntax and all the possible variations…but there are a lot of things that will be
covered, arguably, someone may say that something has been even left out. Therefore,
sometimes I didn’t go into all the details, both not to bore you, and because you can’t learn
everything in one go. I prefer to give you 3 or 4 concepts and tell you how they work, so you
have many more tools and you will be able to do more things. The approach is suitable for non-
technical people that want to learn how to use Excel, being able to do a lot of things from the
first sessions. We can geek-out more in depth in the next books J
 
I now will quickly show you how you can download, install and launch Excel. I highly
recommended you to follow along and actually mirror the content of the book. Only this way
you will be able to learn and consolidate new knowledge. It cannot be a passive learning
process.
I remember when I was studying engineering, I was spending a lot of time learning and doing
exercises, and then, during the day of the test, I systematically had to solve exercises that I had
really never seen before. This is because the courses were designed to make us learn and
understand the concepts in depth, so the future engineers would learn how to think, rather than
just learning by heart and writing the answer down to pass the test.
And this how what I wanted to structure book. You find will step-by-step guides and tutorials,
but you will also be required to use your brain and you are expected to learn the concepts even
if you don’t see exactly all the steps laid out one by one. There is no such a thing as “learn Excel
in 5 minutes”. The learning will happen when you actually do the things, see error messages and
troubleshoot.
When it comes to formulas, for instance, even a semi column or a bracket could cause it not to
work. Nothing to worry about, that’s when the learning happens.
Another thing you need to know is that in Excel there are a lot of different ways to do the same
thing and achieve the same output, that’s why I wanted to teach you a process and a
methodology to improve your decision-making process and your troubleshooting abilities.



Moreover, Excel is a very vast software, so you won’t be able to learn everything about it in one
day. But I can tell you that if you manage to finish this book in under a week, and you are
consistent in doing the exercises, you Excel knowledge will skyrocket. You will learn a ton of
useful information and grasping new concepts from then on, will be easy and fun!
Lastly, don’t get discouraged when things get a bit more difficult. Excel has hundreds of
millions of users, so even if it may sound complex at times, it’s designed to be mainstream and
anybody can learn it at any age.
 
✏   NOTE: Excel can seem pretty overwhelming, especially if you are just starting. 
In fact, even people that consider themselves experts may lack knowledge in some areas of
Excel, depending on how they use the software and for what purposes. 
Perfect! Now that we established that Excel is not going anywhere, we will have a run through
the carers that requires Excel proficiency, the business uses of Excel, and job titles, so you know
what you are sign-up for! This book will give you the knowledge you need. It will help you both
to become more employable and skilled. It will teach you methodologies to analyse data, manage
spreadsheets, create pivot tables, charts, dashboards, automations and much more!
Get ready to become a spreadsheet master. Your journey starts now!
 
To your success,

Robert



If you enjoy video content, make sure to subscribe to our YouTube Channel.
We post tips, tricks, videos, tutorials and step-by-step guides to help you become an Excel
master.
 

Excel Video Tutorial Playlist

 
If you are already proficient with Excel and you want to try the easiest and fastest tool to
create interactive dashboards and client reports from a raw data file in Excel, visit
reportingking.com or scan the QR code below. Reporting King is the fastest Excel automation
tool for charts and reports and you can try it for FREE. Our mission is to make data analytics
easier and accessible to everyone, empower people with Excel knowledge and speed up their
work through software and process automation
 

Try Reporting King to 
Automate Excel Charts

https://www.reportingking.com/




Chapter 1: What is Microsoft Excel?
 



What is Microsoft Excel?
Released for the first time in 1985 for Mac only, Excel is a spreadsheet software application to
organize, store and analyse data. Excel is one of the most important computer programs for
businesses around the world. It’s the dominant standard when it comes to spreadsheets. It’s
flexible, constantly updating, and offers multiple solutions to support a variety of business
processes.
 



Does learning Excel still matter?
As for today, there are over 730,000 companies in the world using Excel and, despite there is no
official data released by Microsoft on the number of users, it is estimated that between 750
million and 1.2 billion people use Excel around the world. Chances are that you are one of them.
Excel is considered the global standard for spreadsheets. It’s integrated across the other apps
within the Microsoft suite, including Power Point, Word, Teams and One Drive. It’s very
customisable, versatile and affordable. It’s the most comprehensive solution when it comes to
spreadsheets.
 

 
Most importantly, virtually every app in the data analytics space has the option to export to
Excel.
There is a joke that is going around in Business Intelligence communities: 
“What is the most used feature in any business intelligence solution?”
“It is the Export to Excel button.”
This is because in Excel you can organize, clean and analyse data, create charts, visualisations
and slides for presentations, key activities in many business processes, as we will see later in the
book.
So, no matter what other software people use for data management, they often have to export to
Excel, because they may need an extra level of customisation that only Excel can give, while
other apps designed for other purposes, cannot.
Simple examples could be: changing the order of the charts, changing size, proportions, layout,
colors, labels, adding functions, and more. Software created for automation have to necessarily
narrow the options available. They can be great for a variety of tasks, but they may not be
designed for every task that businesses need to do at any step of the data management and
analytics processes. In that case, users would export to Excel and continue working. Excel can be
seen as a blank canvas with unlimited customisation possibilities. That’s why it may be more
convenient to do part of the work with Excel, even if you use another tool as your main analytics
tool. In social media marketing, for instance, I have been extensively using Excel to do client



reports, because just exporting the data from the Online Advertising Dashboards (Facebook,
Google, Tik Tok…) was not enough for weekly performance meetings with clients. This is
because they wanted to see data in specific ways, with tables, charts, specific metrics in a
specific order (…) so we couldn’t just simply get away with a screenshot from the ads dashboard
and some commentary: we actually had to prepare templates and build them in a way that was
simply to manage and update every week. This was for every client, every platform and every
campaign.
There are software on the market to integrate, analyse and transform data, such as Tableau,
Google Data Studio, Power Bi (owned by Microsoft) or Qlick Sense, among others.
You can connect these tools to multiple data sources, integrate them, create connections, create
dashboards, analyse data and create presentations.
However, as mentioned, these tools don’t have as many options as Excel and the same level of
customisation and flexibility that Excel provides.
Learning Excel is not only important for work and business. 
Learning how to use Excel means learning how to work with data, regardless if the data will be
analysed with Excel or other tools.
 
To put it very simply:
 

Every business has data, that can be collected from a different variety of sources
Data is always organised in a spreadsheet or in table format
Data has to be in a spreadsheet or a table to be analysed
Data has to be processed and cleaned before starting the analysis
In order to analyse data, you will have to learn concepts such as tables, pivot tables,
charts, functions and formulas

Working with data is a process that often involves cleaning, analysing and presenting.
And those activities can be carried out with many software, but the software that allows the
highest level of flexibility and customisation is Microsoft Excel. In the next chapter, I will
quickly go through careers and job titles that require Excel proficiency, the activities, the
business uses of Excel, and I will show how you can monetize the skills you are about to learn.
And actually, any other skill that you have already! 



Chapter 2: The importance of Excel in Business
 



Careers that require Excel proficiency (with Job Titles)
You may be wondering: what jobs use Excel? What could I do with my outstanding Excel
proficiency? What could I become?
This chapter will provide you with practical information of what exactly you can do with Excel,
what are the uses of Microsoft Excel in business and what are the job titles and the related tasks
that involve Excel. Many of the following jobs will require an Excel test if your initial
application gets accepted.
The good news is that this book is going to provide you with a great wealth of knowledge, from
fundamentals to advanced techniques, tips & tricks, main formulas, shortcuts, process
automation tactics, methodology and thinking.
So, once you decide where you want to take your career, all you have to do is gaining advanced
Excel knowledge relating to that business area.
More importantly, if you lay down the foundations correctly, you master the fundamentals and
you learn how the software works and how to think, gaining that extra knowledge will be easy
and straightforward.
And this is exactly how your path to Excel proficiency has been designed.
 

1. Business Analysis
The most important use of Excel in business is Business Analysis. The process consists of
gathering data and perform analysis to inform the decision makers. This generally happens on a
frequent basis, whether it’s daily, weekly, monthly or any other frequency. Examples of data can
be sales and marketing data, website traffic, spend, insurance claims and more. Business analysts
have to analyse the data and provide actional useful insights for those who run the business.
Examples of this are profitability reports, social media reports showing spend, cost and
performance grouped by age, gender, country, aiming at understanding how to reallocate the
budget in order to reduce costs and increase profit
Job examples: business planning analyst, business solutions analyst, claims analyst, collections
analyst, credit officer, data analyst, data and audience analyst, finance business analyst,
investment operations portfolio analyst, junior data analyst, regional finance analyst, senior data
analyst, senior finance analyst, senior portfolio analyst, business analyst, social media analyst
 

2. Account Management
Excel is widely used for account management. Managers are often required to be proficient in
Excel, analyse data, make presentations, nurture the client relationships, build loyalty and
repeated purchases.



Job examples: advertising manager, design studio account manager, digital account manager,
junior account manager, account coordinator

3. Reporting
Reporting consists of analysing the data and putting them in a presentation for clients or
stakeholders. Despite the Excel charts section is not designed for speed and design automation,
the platform has a lot of design capabilities and allows you to create any type of charts for your
client reports.
You can also build beautiful dashboards and interactive dashboards as we will see in the book.
Job examples: forecast analyst / sales support, performance analyst, performance analyst –
procurement, professional services operations analyst, reporting analyst, reporting development
analyst, sales coordinator, sales operations analyst, financial accountant             
 

4. Strategic Analysis
Strategic Analysis refers to actions like investments, portfolio analysis and asset allocation. 
Analysts use formulas and spreadsheets to generate models, predict scenarios and get more
support during the decision-making process.
Job examples: mergers and acquisitions valuations - analyst, membership and campaigns
strategist, portfolio administration associate, portfolio analyst, portfolio associate - wealth
management, portfolio management officer – asset finance, asset manager realty management
division
 

5. People Management
One of the most common uses of Excel is building databases in a spreadsheet (the database can
be seen as a table with information and data grouped in specific ways). Many companies use
Excel to manage people, because storing information in a spreadsheet is particularly convenient.
You can write information about people, whether they are employees, customers, supporters or
others. You can write attributes, notes, and create a spreadsheet with rows and columns with all
the information (such as name, surname, email address, status…). Excel allows you to easily
store and retrieve information at any moment, as we will see in the book.
Job examples: client management and administration, client relationship manager, client service
manager, client service specialist, employer service consultant, HR administrator, human
resources administrative assistant, human resources administrator, human resources adviser,
human resources officer, junior HR analyst, reconciliation and payments officer, relationship
manager, client growth coordinator
 

6. Program Management



Excel can be used to manage programs as well. Thanks to its flexibility, people can use it to
manage specific programs or projects.
It’s easy to manage and can seamlessly handed over to new people in case of turnover.
Job examples: project leader, program manager, project portfolio manager

7. Operations Management
Excel can be used to manage operations as well. It’s easy to use, it doesn’t require code and
doesn’t require a high skill level. You can use it to keep track of your operations, write dates, use
formulas and record all the information you need. You can update the Excel spreadsheets
anytime you need (manually or via automation) and always know where you are in the process.
Job examples: data operations manager, graduate program – supply chain and operations, in
market supply chain analyst, operational business analyst, operational enablement associate,
operational knowledge management specialist, supply chain associate, supply chain specialist,
business operations analyst
 

8. Office administration
Excel is often used for record-keeping, supporting day-to-day tasks, accounting, financial
reporting, scheduling appointments, organizing documents, business analysis, performance
reporting and more. Excel is a very useful tool in office administration, it’s multipurpose and
support workers during their office activities, such as paying bills, invoicing, keep client
information organized.
Job examples: administration officer  administration supervisor, administrative assistant,
business operations and office manager, junior clerical and administrative officer, office admin
manager, office support – maintenance / general duties, administration assistant
 

9. Project Management
Despite companies have project management software to support their PM activities, Excel
represent a valid alternative: you can use it as a database, you can create diagrams, design, add
formulas, create dates and keep track of deadlines and much more. Excel very high versatility
makes it a good tool for Project Management as well, easy to use and to share with other people
that may not have or may not be proficient with more advanced Project Management software.
Excel allows PMs to stay on top of the project and ensure everything is always on track, they can
use Excel to connect and consolidate data sources across different business departments, such as
resource allocation, employees work, supplier relationships, and more.
Job examples: project business analyst, project assistant / officer (IT), project analyst.
 

10.                    Contract Administration



Excel has a lot of pre-made templates, including contract management templates. They can be
used and edited to adapt to a particular contract, depending on the stage the employee is in. You
can use it for these types of tasks as well, and manually build your template to organize the
information as you need.
Job examples: contracts administrator, estimator / contracts administrator, graduate contracts
administrator, lease administrator, quote and tender administrator, building contract
administrator



11.                    Sales Management
Sales manager set goals and targets and manage people. Excel represents a great solution to keep
all the information organized in the same place without having high level of technical skills or a
coding background (sales is a skill that traditionally doesn’t require high-level computing skills,
so this is another reason why it is suitable in this field as well)
Job examples: Sales Manager, Digital Sales Manager, Enterprise Sales Specialist, Senior
Business Manager, Sales Executive, Business Development Manager, Regional Sales
Manager, Sales Specialist
 

12.                    Cost estimator
Excel allow to seamlessly create formulas and link them logically to understand what is going to
happen if one of the parameters change. If you work in cost analysis, Excel is a very important
tool to learn as it allows you to quickly setup models and analyse scenarios in a short time. Also,
it’s very customisable and allows to combine tables, text and charts in the same spreadsheet,
which makes it very handy when it comes to keeping track of information. It’s also very easy to
share, making the information transfer process easy and fast.
Job examples: Cost Analyst, Cost Controller, Cost Engineer, Cost Manager, Cost
Estimator, Cost Control Specialist, Senior Cost Accountant, Assistant Plant Controller, Senior
Cost Analyst
 

13.                    Accountant
Being familiar with Excel is one of the requisites when it comes to jobs in accountancy.  Despite
accountants may be using accountancy software for work, having at least a basic understanding
of Excel is often required by employers, especially because understanding Excel means
understanding datasets, spreadsheets and functions regardless in which software they are carried
out.
Working as an accountant, you will have to work with financial statements, submit tax returns,
manage cashflows and income statements. Excel can be used to keep track of all this info (even
on a personal / organizational level) as it’s very simple to use and versatile if you need to edit
data or manually add information.
Job examples: Financial Accountant, Management Accountant, Junior Accountant, Chartered
Accountant, Senior Accountant
 

14.                    Economist
For those who work in finance or apply economic concepts, Excel is one of the most important
tools to analyse, report and manage financial data and a must know.



Job examples: Assistant Economist, Junior Economist, Associate Consultant, Accountant,
Senior Economist, Account Manager, Assistant Manager, Assistant General Manager
 

15.                    Statistician
Excel allows to create, manipulate, organize datasets, use formulas, make predictive analysis and
much more. Excel is definitely one of the tools you need to master if you want to become a
statistician and work with numbers. As mentioned, it’s considered the dominant standard for
spreadsheets, so it contains everything you need to analyse your data and extract practical
insights.
Job examples: Statistics Specialist, Statistician, Statistical Analyst, Senior Statistician, Statistical
Consultant, Senior Data Scientist, Senior Data Analyst, Research Assistant
 

16.                    Market Research Analyst
Excel provides a framework to quickly import / copy-paste / clean and format virtually any data.
Market analysts use excel to analyse survey or dataset and prepare the data for further analysis or
synthetise them to produce insights and learning.
Job examples: Market Research Assistant Marketing Assistant, Assistant Account
Executive, Market Research Consultant, Market Research Interviewer, Market Research,
Associate Market Research Executive, Market Research Director
 

17.                    Retail management
Excel can be easily used in retail management to keep track of information that would be
otherwise disconnected and stored in different software or directories. You can create an Excel
sheet and keep track of expenses, costs, employees, payments, holidays, sick days, leaves, sales,
inventory and much more. Excel provides a sort of white canvas where you can easily build your
database according to your needs. When it comes to retail, you can also use Excel to manage
product information (for instance in the ecommerce space) or download data from your website
(export to Excel) and analyse it to better understand your performance, reduce returns, increase
profits and much more.
Job examples: Retail Specialist, Retail Manager, Retail Sales Specialist, Assistant
Manager, Sales Assistant, Retail Assistant, Retail Store Manager
 

18.                    Quality Analyst
Whether it’s quantitative analysis (based on numbers) or qualitative (based on non-numerical
data that need interpretation), Excel provides a great framework to store and analyse data,
measure, interpret, analyse and decipher.



Job examples: Quality Assurance Specialist, Quality Assurance Manager, Quality
Specialist, Quality Engineer, Senior Quality Control Analyst, Quality Assurance
Analyst, Quality Analyst, Quality Control Engineer, Quality Control Inspector, Senior Quality
Assurance Specialist, Quality Assurance Engineer
 
 

19.                    Self-employed / Freelancer / Contractor / Digital Nomad / Remote
Excel skills are highly monetizable and, once you become proficient, this can allow you to work
remotely, on your own terms, whether it’s on fixed term contracts, retainers, large project, or
small gigs.
There are a lot of platforms for freelancers where you can start generating money with your what
you know, but the best one is undoubtedly Fiverr, the largest marketplace where you can setup
your portfolio and sell your skills. On Fiverr there are a lot of freelancers skilled in Excel
(analytics, reporting, dashboards, automation, which can be also adapted to different niches), but
also in other fields like social media marketing, strategy, accountancy, design, photography (….).
Once you define your skills, you can create your portfolio and sell your gigs. You can apply for
jobs that have been posted and get potential customers to reach out to you to enquiry about your
services.
It's very fast to setup, designed for fast and efficient client-communication and can allow you to
monetize your skills from anywhere, on your own terms. It’s usually the starting point for more
freelancers and people that want to get out of the corporate world and start creating side incomes.
I used to work on Fiverr quite a lot in the past, and I also bought a lot of services for my projects
from other freelancers.
Take a look at the Fiverr marketplace and sign-up to create an account. It’s absolutely 100%
FREE, and you can start typing in Excel related keywords (or other keywords, if you already
have skills, passions, things you are good at, you can start monetizing them very fast) get
inspiration and ideas on what skills you can sell and how to better package them to attract more
offers.
 





Search how other freelancers are already using Fiverr to make money, and get an idea of what
they are doing. If you are interested in working remotely and generate another stream of income,
I would recommend it to you. (Make sure you explore all the niches)
 

 

       

 



Get started with Fiver here, sign-up for free
 

Link if you are reading this from Kindle: http://www.fiverr.com/s2/445c5570b3
QR code if you are reading the paperback version of the book

http://www.fiverr.com/s2/445c5570b3


Versions of Excel
Since its release in 1985, there have been more than 30 versions of Excel. 
Nowadays, the majority of the users have Excel 2016, 2019, 2021 or Excel 365.
✏   NOTE:  each version of Excel is slightly different from the others. Also, within each version,
there are difference between the Mac and the Windows version as well. This means that some
functions may be available in some versions but not in others, so as the interface may look
different, and the options available like shortcuts, tabs and so on may differ from one version to
another. There may be things that you will be able to do and things you may not, that’s why we
will focus on the approach to solve problems, and find different ways to work around the
problem based on the version of Excel you have. And be creative! Make sure you know what
version you are working on, so you can better understand what you can do and what you can’t do
when searching online. If you have already installed Excel, click on the top left corner, click on
Excel > About Microsoft Excel. 
You will be shown a prompt with your information and the version of Excel you are using. (I am
using Excel 2019, just depending on the last version that was available when I purchased the
software)

          
 
Troubleshooting and finding workaround is going to be part of the equation during your entire
Excel journey, so some level of flexibility is required.
You are about learn the Excel must-know features, using commands that would more likely work
across most of the Excel versions. Let’s get started!



How do I get started with Excel?
Excel is a spreadsheet software that works on your computer and you don’t have to be connected
online in order to use it. In order to get started with Excel you have to purchase a licence,
download the software, install and launch.
 



How to get better with Excel
Excel may feel a bit complex at times, given the vast number of possibilities and options it
offers. 
But you will never need to know the entire software inside out. 
Which would be incredibly remarkable and unique.
It’s important you understand why you need Excel for (what job you want to apply for, needs
you may have when it comes to organising or analysing data), focus on those functions,
processes, shortcuts that you need for your purpose. And build from there.
Second: the more you will use Excel, the more you will learn. Don’t get discouraged if you
don’t know how to do something: being constantly learning is part of the process, especially
when it comes to learning a software as elaborate and multi-layered as Excel.
Third: watch tutorials, videos and documents. Microsoft partly relies on advocates, influencers,
specialists that keep constantly pushing out tutorials, exercises, tips & tricks on their blogs,
platforms and channels, with more in-depth explanations than the official documentation.
This will help you dispel your doubts better than the official documentation in many cases.
You can find the official Microsoft Excel knowledge base here:
https://support.microsoft.com/en-us/excel. You may want to bookmark this link and checking it
as a starting point every time you have questions.
Fourth: understand the foundations, and try! Make mistakes, troubleshoot them, and learn!
Fifth: get your Excel file open and get ready to replicate the steps I am going to show you: you
can’t learn passively; you actually have to do it.

Let’s go!

https://support.microsoft.com/en-us/excel


Chapter 3: Start Using Excel

How to download Excel
You can get download Excel at this link: https://www.microsoft.com/en-us/microsoft-365/excel
Or, from your laptop, go to Microsoft.com and click on Excel.
Click on Buy now and select the option that best suits your needs.

 
You can buy a multiple license and share it with your friends or you can buy one single license
and decide to pay it monthly or yearly and save 16%.
You can also start a FREE trial for a month in case you don’t want to spend any money during
the initial phase and try the software more freely. If you download Office 365, your version of
Excel will work from desktop, mobile and web. By downloading Office 365 you will also have
access to the other software withing the Office Business Suite across different devices and
operation systems.
 

 
 

https://www.microsoft.com/en-us/microsoft-365/excel


How to install Excel
Once you have decided which plan you want to go for, go ahead and purchase the licence,
download Excel and install it. The installation process follows the standard workflow and we
will not cover it in depth here. Once the installation process is complete, double click on the
Excel icon and launch it.
 



How to get started
Double click on the Excel icon to launch the program. 
 

 
This will open a new blank Excel File, where we will be working.

      
 
As you can see on the right, when clicking on File on the top left corner of the screen, you will
be able to save, name, and open, close your workbooks anytime you need.
 
We are in!



Chapter 4: Excel Basics and Fundamentals
 



Excel definitions
WORKBOOK: a Workbook is an Excel File containing one or more Spreadsheets.
 
SPREADSHEET: a Spreadsheet (also named Worksheet or Excel Sheet) is a sheet made of
rows and columns that you can use to input data, sort and organize it and make calculation.
Rows are labelled with numbers, from 0 to 1,048,576, while columns are labelled with letters
from A to Z and then, after the letter Z, they are labelled with 2 letters (starting from AA to the
final column XFD with over 16,000 columns).

              
 
RIBBON: the Ribbon is the grey section between the Spreadsheet area and the green formula
bar of the screen. It contains a lot of options to work on your data and we will learn more about it
during the course of the book.
 
CELL: a cell is the smallest editable unit contained in a Spreadsheet. It’s the intersection of a
column and a row. In the picture above, we can see cell A1 selected. The selected Cell Reference
is shown in the box right above.
 
Excel is a Spreadsheet Software, that allows you to create Workbooks (Excel files), which are
collections of Spreadsheets (Worksheets), single individual sheets where you will actually do the
work. Other examples of Spreadsheet Software are Google Sheets, iWorkNumbers and Open
Office. They all allow you to create files that include sheets to organize data and calculate
numerical values.



Excel basics
Once you launch Excel, you are presented with a blank workbook. 
Let’s have a look at a few shortcuts and commands to manage the file. Make sure you follow
along so it will be easier for you to learn and memorize.

QUESTION: How do you open a blank new workbook in Excel?
✂   SHORTCUT: CTRL + N 
⏱   MANUAL: Click on File > New
 
QUESTION: How do you open existing workbook in Excel?
✂   SHORTCUT: CTRL + O
⏱   MANUAL: Click on File > Open > Select the file you want to open
 
QUESTION: How do you save a workbook in Excel?
✂   SHORTCUT: CTRL + S
⏱   MANUAL: Click on File > Save
⏱   MANUAL: Click on the Save Icon on the upper left corner of the screen

 
Name your file and select the format. Depending on what you want to achieve you may want to
choose a different format. I personally choose between .XLS .XLSX or .CSV format. Please note
that if you change your file format while saving you may experience data loss, so make sure you
select one of the standard formats unless you are given different instructions or you need to work
with VBA (Visual Basic for Applications). In that case you would select Macro Enabled
Workbook .xlsm.
 
QUESTION: How do you close a workbook in Excel?
✂   SHORTCUT: CTRL + W
⏱   MANUAL: Click on File > Close
 



QUESTION: How do you add new worksheets in the workbook?
ANSWER:  Once you create a Workbook, you will start working on Sheet 1, which is created
by default.
Simply click on the + sign near Sheet 1 on the bottom and new Sheets will be automatically
added. You can add up to 255 sheets before saving your file and even more afterwards,
depending on how much space you have in the destination folder. You will not need all those
sheets for the moment
 

 
 
QUESTION: How do you edit or remove worksheets?
ANSWER:  Double click on Sheet 1 (or any other Sheet) to change the name
Right click on Sheet 1 (or any other Sheet) to display the full list of options, such as renaming,
hiding / unhiding, duplicating, protecting, delete, change color and more.
 

 
Now that you are familiar with the Worksheet basics, let’s see how Excel actually works.
Place your mouse pointer on a cell and click. You will see the cell border becoming green
(showing the cell is selected) and the address of the selected cell displayed on the top left corner.
B2 is now the “active cell’, as it’s currently selected. B is the column index, 2 is the row index.
These, combined, are called “cell reference”.



 
Once the cell is selected there are several ways to input values within it

1. Just start typing over numbers or text and press enter when you are done
2. Click on the formula bar, start typing numbers or text there, and press enter once you are

done
 

As you can see, the formula bar shows the selected cell content, whether is a number, a text
string or formulas as we will see later in the book.
Also, below “Paste” in the top right corner of the ribbon, you can see the cell reference. B2, as
the active cell is in column B and row 2, and this is reflected (these coordinates are called cell
reference or cell address)
 
QUESTION: How do you expand the formula bar?
✂   SHORTCUT: CTRL + Shift + U (to expand and resize) 
⏱   MANUAL: Hover over the lower border of the bar until your mouse icon becomes a resize
icon. 



Click and hold as you drag the bar border up or down to resize the bar.
 

 
QUESTION: How do you edit a value in a cell?
✂   SHORTCUT: Click on the cell you want to edit and click F2 to step in and edit the value
⏱   MANUAL: Double click on the cell you want to edit to step in and edit the value.
⏱   MANUAL: Click on the cell you want to edit to select it and just type over a new value
⏱   MANUAL: Click on the cell you want to edit and change the value from the formula bar
⏱   MANUAL: Click on the cell and press BACKSPACE or DELETE to clear the content

These shortcuts are particularly useful when it comes to editing the content in a cell (whether it is
a value, a text or a formula), rather than just typing over and delete the previously existing
content.
 
 



The Ribbon
The Ribbon is the upper section of the interface between the branded green Excel bar and the
worksheet with the cells.
The ribbon includes the commands and instructions to manipulate your data set.
We will not explore every section and sub-section of in the ribbon, but we will cover the most
important things you need to do beginner, intermediate and advanced level tasks.
The ribbon is divided in section, you can access each section by clicking on it
 

 
1. Home contains commands related to creating, formatting, and editing a spreadsheet.
2. Insert contains commands related to adding items to a spreadsheet such as graphics,

tables, pivot tables, charts, headers and footers, hyperlinks etc…
3. Page Layout contains commands related to printing a spreadsheet.
4. Formulas contains commands related to formulas
5. Data contains commands related to importing and editing data
6. Review contains commands related to commenting, proof reading, tracking changes or

protecting the spreadsheet.
7. View contains commands related to the layout the spreadsheet.

 
In addition to these 7 Tabs, there is an 8th one called the Developer tab that is hidden by default.
The Developer tab contains commands related to recording macros and writing visual basic for
application (VBA) code. This tab is hidden by default as most people will likely never want or
need to use it.
VBA is the Excel coding language and allows you to create automations through simple code
and it will not be covered in this book. I personally love it and used it a lot! But it’s because I
enjoy coding.
Once you create Pivot Tables, as we will see in the next chapters, the ribbon will also add new
sections named Pivot Table Analyse, that will allow you to control and customise the table.
The same will goes with Charts.
The ribbon includes a lot of different options and commands and it can also be customised
to add quite a few options that are not visible by default. It will be very long to list all the
options here, so we will go through some of the ribbon options to solve exercises and accomplish
goals as we go through this book. So, by the end of it, you will have complete understanding of



the ribbon and you will be invited to explore it further should you need new options to work on
your data in future.



Excel Fundamentals
 



Drag & Drop
Once you select a cell (or a range of cells), you will see the cursor icon change based on where
on the cell you will place the cursor. You can place it outside the cell, on the side or on the
bottom right corner, where you can notice a small square, which I will refer to as anchor point,
because it actually allows you to anchor to the cell to drag and drop it.
 

 
When you place the cursor on the side, the icon will become a hand (picture in the middle here
above). 
If you hold, you will be able to drag the cell around the worksheet and drop it where you want to
release it.
Try to drag the cell in B2 and release it in B6.
 

As we will see in the book, there is more than one way to do the same thing in Excel, and this is
just one of the many.
The same principle applies to dragging and dropping ranges. Both tasks can also be
accomplished through shortcuts, typing via the keyboard.
 





Drag cells in Excel
One of the Excel fundamentals is dragging a cell to duplicate it or to autocomplete a pattern.
Hover over the small square on the bottom right corner of the selected cells and you will see the
cursor icon changing. Click and hold. Now you can drag the cell (or the range) to the left, to the
right, to the top or the bottom, for as many cells as you need.
 

 
Let’s see it through an example. On your opened file:

1. Select the cell in B4 (click on B4)
2. Type in the value 12 and press Enter
3. Hover over on the bottom right corner of the cell B4 on the little green squared anchor

point
4. Click on the anchor point and hold, while dragging the cell down to B9
5. Release in D9

 

     
 
As you can see, dragging the cell down gave Excel the instruction to fill in the sequence. Excel
filled in all the cells with the same value you started with. So, at this point, you should have 6
cells (from B4:B9) with the same value as B4.



6. Select B9, hold the bottom right corner of the cell as in point 3
7. Drag the cell to the right and release once you get to D9

 
You should now have the same value in 3 more cells (B9:D9) as a result of dragging the cell.

    
 
Dragging a cell (or a range) to fill the near cells is one of the most important things to master in
Excel. You have just learnt how this works with one cell at a time in multiple directions. As we
will go through the book, you will learn how to select cells in multiple ways, drag multiple
ranges, fill cells following patterns, and much more.
For now, just remember: hold the bottom right corner of a cell, drag and release.

Now, let’s clear the content and remove everything we wrote in the Worksheet. 
Use your keyboard to execute the shortcuts. 

Select every cell in the worksheet
✂   SHORTCUT: CTRL + A
 
Delete content
✂   SHORTCUT (Mac): Backspace
✂   SHORTCUT (Windows) : CTRL + Shift + Delete
 
 



How to move through a dataset
You will use Excel, among others, for calculations, formulas, analytics and data set management.
Mastering cells selection is going to be crucial to speed up your work and move through data sets
fast.
 
QUESTION: How do you move through a dataset in Excel?
ANSWER: Using the keyboard arrows and combine them with keyboard buttons to leverage the
shortcuts.
 
HOW TO MOVE ONE CELL AT A TIME
In your document, create a simple 3x4 table like the below.

1. Select the cell B1
2. Click on keyboard arrows to move within the table and outside the table

This is the most basic way to move through the Worksheet, one cell at a time.
 

 
HOW TO MOVE MULTIPLE CELLS AT A TIME

3. Select the cell B3
4. Hold CTRL
5. Click on the Right Arrow (keyboard)

 
You should have now jumped to E3 in one click
 

 
6. Now, while still holding CTRL, click on the Down Arrow

 



You should have now jumped to E5 in one click
 

7. Using CTRL + the Keyboard Arrows, you should now be able to move along the
following to the 4 corners of the table

 
The combination CTRL + Keyboard Arrows will allow you to move from a cell to the last
non-empty cell in that direction. Therefore, if you use the command to go in a direction where
all the cells are empty, you will be redirected to the end of the Worksheet. If that happens, you
can:
 
⏱   MANUAL (FAST): Hold CTRL + Keyboard Arrow in the opposite direction to what you
have just done
✂   SHORTCUT: CTRL + Home
✂   SHORTCUT: Type A1 in the reference bar (top right corner)
✂   SHORTCUT: Click CTRL + G to open the Go To panel and type A1 under Reference. Press
Enter.



 
Cell Selection
So far, we have learnt how to drag a cell, how to select a single cell, how to move through the
cells one step at a time or multiple steps at a time.
We will now learn how to select multiple cells at a time.
 

1. Select the cell B4
2. Hold SHIFT
3. Click 3 times on the Down Arrow

 

 
You should have now selected the entire first column of the table (B4:B7)
 

4. While still holding SHIFT, click and hold CTRL
5. Click on the Keyboard Right Arrow

 
You should have now selected the entire table.
 



 
Now you can play around and select any cell of the table, hold SHIFT + CTRL and click on the
keyboard arrows to get familiar with this selection process (selecting multiple cells at a time).
 
Last but not least, another way to select multiple cells at a time that you need to know is
 

1. Select the starting cell
2. Click and hold the right button
3. Move around with the mouse or the cursor to perform a manual selection
 



Drag a range
RANGE: a range is a group of one or more contiguous cells. As you may have already
understood, we refer to ranges in Excel by referencing the first and the last cells of the range,
starting from the top left.
Let’s start from scratch. Select every cell in table however you want and delete content.
 
✂   SHORTCUT (Mac): Backspace
✂   SHORTCUT (Windows): CTRL + Shift + Delete
 
à  Create a new table like the below
 

1. Now click on B4 and select B4:B7 however you want
2. Once all the cells are selected, hover over on B7 bottom right corner and hold the anchor

point
3. Drag the selected column to the right, up to column E.
4. Release

 
You should have now duplicated B4:B7 into C, D and E, with identical values (second image).
Dragging cells will instruct Excel to duplicate them exactly as they are or to fill in a sequence of
values, when Excel recognizes a pattern.
Dragging a selected column, allowed to duplicate it to the right as it is.

We are about to explore the drag command further. You will understand how to leverage its
potential to the fullest and learn how to manipulate your spreadsheet like a pro.
Moving through cells, selecting cells and dragging cells are among the Excel fundamentals and it
is therefore essential for you to master these tasks. 
 

  



 



The formula Bar
When you select one cell, the formula bar in Excel shows one of the following
 

a. The same value displayed in the cell
b. The formula contained in the cell, if a formula was typed

 
Let’s have a look at the most basic formula in Excel, which is when a cell is = to another cell.
While it may seem very simple, we will learn how it can massively help you automate and even
analyse entire datasets in a matter of clicks. This is one of the main things to remember: master
the fundamentals, understand the basics, so when you will have to implement advanced
strategy or try new things it will be much easier, as you will have acquired a new way of
thinking.
You will be able to leverage simple concepts to solve complex problems.
 

1. Select the cell B8
2. Type =
3. Click on the cell B7
4. You will notice that both in B8 and in the formula bar it’s displayed =B7
5. Press Enter to confirm

 

 
6. You can now click on B7 and type over Hello, to see the value in B8 changing to Hello as

well
 



 
This is what happens when one cell is equal to another cell.
 



Dragging cells with formulas
When dragging a formula (in this instance the formula =B4 in cell B3), Excel will drag the cell
and the cell reference values (the row and the column indexes in the formulas, here B and 4)
following your instructions
 

1. Drag B8 to the right and release on E8
2. Select E8 and notice that the formula is now =E7
3. Select D8 and notice that the formula is now =D7
4. Select C8 and notice that the formula is now =C7

 

 
What happened here is that Excel dragged the formula to the right and changed the column
index (B > E), while the row index (7) hasn’t changed. Each cell in Row 8 within the table is
equal to the correspondent cell in Row 7 as a result of dragging the formula to the right.



5. Select E8 and drag it right one more cell and release in F8. F8 will be populated with a 0.
6. This is because F8 is now = F7. F7 is empty, so F8 = 0

You can see it from the cell, the formula bar, and also with a special shortcut to hide and show
all the formulas in your spreadsheets.
 

 
QUESTION: How do show/hide all the formulas in the worksheet in the spreadsheets (on/off)?
✂   SHORTCUT (Mac): CTRL + ~ 
✂   SHORTCUT (Windows): CTRL + ‘
⏱   MANUAL: Ribbon > Formulas > Show Formulas
 



Absolute Reference
QUESTION: How can we drag cells with formulas in Excel and avoid these problems?
ANSWER: In order to drag your formulas without incurring in this type of problems, you will
have to use Absolute Reference.
Absolute Reference will allow you to lock the column index, the row index or both, so you will
be able to create your formulas and drag them where you want with no errors. To add Absolute
Reference, you simply have to add a $ before the row, the column or both in the formula
 
EXAMPLES

-          B4 = reference to a cell in a formula
-          $B4 = dollar sign before the column. The column index will be locked to column B
-          B$4 = dollar sign before the row. The row index will be locked to row 4
-          $B$4 = both cell row and column index are locked, so the formula will have the same

value as B4 everywhere you drag it
 
✂   SHORTCUT: select the cell with the formula and then select the cell reference within the
formula from the formula bar. Then press F4 to cycle through Absolute Reference (F4 once to
lock columns, F4 twice to lock rows, F4 three times to lock both, F4 four times to unlock both)
⏱   MANUAL: Type the dollar sign everywhere you need in the formula
 

 
Let’s see another example
This time I am creating a formula to calculate the discount I received with a specific offer during
each month of the year. As you can see, the discount is in cell C2, so if I want to drag down my
formula in D6, I have to lock the rows with absolute reference. There is no need to lock the
columns as well, at this stage, because I am only going to drag my formula vertically.
 



 
As you can see, I can drag down my formula and C$2 won’t change, while the reference in the
Amount column will follow the pattern of the formula as I drag it down.
 

 
You can lock the column when you need to drag the same cell horizontally, or lock rows and
columns if you need, for instance, to drag cells from a specific table across formulas in the
spreadsheet.
 
Let’s do a quick recap, what you have learnt so far.
As for now, you should be able to

Type within cells
Type over
Double click to edit text within a cell
Select cell and type in the formula bar

Move through the data set
Manually with cursor



Keyboard arrows & shortcuts to move faster
Select cells

Manually with cursor
Keyboard arrows & shortcuts
Select single cells, ranges and tables

Drag cells
With one or more cells selected, drag the anchor point in any of the 4 directions to
duplicate cells or follow patterns (as we will see in the next section)

Understand formula basics
Type =(Column, Row) to link two cells

Drag cells with formulas and use Absolute Reference
You can drag and duplicate cells with formulas
Rows and columns references will vary accordingly
You can lock them using Absolute Reference



Drag cells and fill-in a pattern or a sequence
Now let’s work on another example to apply what we learnt and level up our skills.

1. Let’s create a table with the following headers: Customer ID, Item, Quantity, Price,
Revenue

2. Write the values in the cells as below

 
Now we will drag multiple cells
 

3. Select cells B3 and B4
4. Click on B4 lower anchor point
5. Drag down until B9

 
As you can see, Excel recognized a pattern between Customer 1 and Customer 2 (selected) and
guessed how you wanted to autofill the cells below when dragging those 2 down. When you
select multiple cells and drag them simultaneously, Excel will look for a pattern and will fill-in
the sequence accordingly.
 

6. Select cells C3 and C4



7. Click on C4 lower anchor point
8. Drag down until C9

 

 
The pattern recognized by Excel is in this case is the alternance of two string values (Blue shirt
and Red shirt), that will be replicated according to the starting sequence selected
 

9. Repeat the same step for Quantity

 
Excel has now recognized the pattern “step 30” and will replicate it automatically (there is a step
30 between 100 and 130, so Excel will fill it down with 130+30, 160+30, and so on.
 
✏   NOTE: You could have also done the last 3 steps in one action, by selecting the range



A3:D4 and drag and drop the range down (one single selection and dragging down the range, as
shown in the next image)

 
10.                    When you get to the column Price, just manually type in the 2 prices throughout

the sequence
 
The reason is that we only have 2 prices for 2 items, and if you try to drag and drop E3+E4,
Excel will fill in with prices with step 3. You are welcome to try it yourself, and then undo with
CTRL + Z.
 

11.                    Add a header in F2 and write Revenue
12.                    Click on F3 and type =E3*D3 and press Enter

You have now calculated a formula with 2 cells.
 
You can do it as well by



clicking on F3, step in the cell with double click and insert =
then click on E3
then type *
then click on D3 and press Enter

 
13.                    It’s time to drag it down to calculate the revenue that every customer brought in,

and you can do it in 2 ways:
a. Drag down the cell while holding on the anchor point
b. Double click on the anchor point

 
✂   SHORTCUT: double click on a cell anchor point or range anchor point to fill the sequence
down
 
A double click on the anchor point is a shortcut for drag & release. It works in tables and will fill
the sequence down until the last non empty cell.

       
 
Once you select a cell or a range, double clicking on the anchor point will auto-fill the
sequence down, up to the last non empty cells on the nearest column.
This last formula will complete the sequence down until an empty cell is found in the column on
the left.
 



 



Column Selection
In order to select all the columns in a table and beyond (select the entire column) do the
following

1. Click on the D header of column D
2. Hold and drag the selection up to F, the last column

        
 
Change column width
Now let’s autofit the columns. Autofit is a command that allows you to adjust the column width
in order to fully display all the values within the cells in the column. It’s particularly useful when
you have long values in the cells and you can do it in two ways
COLUMN AUTOFIT: Double click in between 2 row headers in the selection (e.g., between C
and D, or D and E or any other in-between space between two columns). This will fit all the
columns size.
 

 
MANUAL COLUMN FIT: If you notice that the column size has become too small or too big,
you can adjust it by resizing one specific column or all the columns to the same size.
Select again all the columns. Select Column C, hold and drag the selection up to column F.



Now click on the same space in between two columns, but instead of double clicking, just hold
and slowly drag to the right. You will see a label showing the width changes.
Once you release, all the columns selected will have the same size.
You can also do this with one column at a time, to give the table the exact look you want.

 
 
It may happen to receive a data set that we may define “messy”, using a colloquial expression, so
you may have to spend some time in just by improving the visualisation before starting to work.
You can see an example. Notice how column F is so small, that the values are not displayed,
instead we see a set of #### and we need to increase the column size.
 

 
Select all
✂   SHORTCUT: CTRL + A
⏱   MANUAL: Select rows and columns manually
COLUMNS AUTOFIT: Double click on any space in between two columns to fit the columns
 



 
ROWS AUTOFIT: Double click on any space in between two rows to fit the rows

 
Now let’s continue the exercise by adding new shortcuts, tips and tricks that will level up your
skills, as we keep progressing with the task complexity.
 



Formatting Shortcuts & tricks
Select every cell in the worksheet
✂   SHORTCUT: CTRL + A
⏱   MANUAL: Click on the top right button between Row 1 and Column A
 
Change background color
Once the cells are selected, click on the color background icon and select white (Ribbon >
Home)
The grey border lines should have disappeared.
To make them re-appear, just repeat this process but select “No Fill” instead of white

 
 



Apply bold formatting to the headers
Select the headers in the table
✂   SHORTCUT: CTRL + B
⏱   MANUAL: Click on the B icon on the upper left part of the screen
 

 
Add outside borders to the table
Select the full table
✂   SHORTCUT: CTRL + Shift + & 
 
Add all borders to the table
Select the full table
✂   SHORTCUT: Press CTRL + Shift + - to remove outside border (optional)
⏱   MANUAL: Click on the Border Icon in the ribbon and get full access to all borders, you can
change colors, border type, thickness and more
 



Text Align
Select the entire table (or select the columns by selecting them from the headers as shown above)
and click on the Centre Text button or any other option from the Ribbon (Centre left, Centre
right).
 

 
As you can see the table starts to look cleaner and better designed. But all the numbers look the
same and lack formatting, so we still need to work on it.
 
Number Formatting
Select all the Price and Revenue cells or simply select columns E and F, then you can

1. Click on the little down arrow near the coin sign and select your currency
2. Click on the little down arrow near the coin sign and select “more accounting formats” if

your currency is not there
3. ✂   SHORTCUT: select the cells and click CTRL + 1 to open the currency formatting

panel
4. Use other shortcuts we will show later to automatically format the currency in dollars

 

 



Adjusting decimal points
You can adjust the number of decimals points both in the formatting panel and within the main
interface. You can increase and decrease decimals by clicking on the buttons near the currency
icons in the ribbon.
 

 
Copy, Paste, Cut
You are about to learn simple commands that work across the entire Microsoft Office Suite
✂   SHORTCUT: Select the entire table and press CTRL + X to copy and cut it
Select cell H3
✂   SHORTCUT: Click CTRL + V to paste table (we moved the table from B2 to H2)
 

 
This command will allow you to move cells from a point to the other (cut and paste).
You can obtain the same result by selecting the full table, holding the border of the selection
(until you see the hand icon) and simply drag and drop the entire table to another place in in the
worksheet.
 
✂   SHORTCUT: You can instead copy-paste values by using the shortcuts CTRL + C, CTRL +
V



This will duplicate your table, leaving the original table in B2 and creating a copy wherever you
paste it.
 
Undo Action / Redo Action
✂   SHORTCUT: CTRL + Z to undo action
✂   SHORTCUT: CTRL + Y to redo action
You can also do the same tasks by clicking on the arrows on the upper-left side of the screen

 
Add and remove filters
You can add filters to tables. Filters will allow you to sort the table values in different ways or
show only specific values that match selected conditions.
Select the entire table
✂   SHORTCUT: Click CTRL + SHIFT + L to add filters
⏱   MANUAL: You can click CTRL + SHIFT + L to toggle the filters off, and you can
manually do it by clicking on the funnel icon on the upper right corner with the text “sort and
filter” in the Home Tab.
 

 



Once you have applied the filters, click on the filter icon in the Revenue header cell. 
You can now edit the entire table by applying conditions to the Revenue Column.
You can sort the column in ascending or descending order
you can hide / show specific values by unticking / ticking them
you can also create numerical conditions by clicking on “choose one” from the sort panel
 

You can remove all the conditions applied in 3 ways
✂   SHORTCUT: Select the table and click CTRL + SHIFT + L to remove the filters and any
condition
⏱   MANUAL: Select the table and click on the funnel icon to remove filters and conditions
✂   SHORTCUT: Click CTRL + Z to undo action(s)
 
Filters is one of the most important features in Excel. Mastering filters will allow you to
quickly analyse and process your data, managing large datasets and find the insights you need in
a blink of an eye.



 
Excel Formulas
Sum, Count, Average
You have previously learnt how to create a formula by multiplying two cells (price and units to
calculate Revenue, or discounts) and using Absolute Reference when dragging cells containing a
formula. It goes without saying, that as you can multiply two values within two cells, you can
create mathematical formulas as well. Excel has also a vast set of pre-made functions you can
use to your advantage to speed up your work. We are now going to learn:
 

Sum() = returns the sum value of the cells selected in a range
Count() = returns the number of items in a selected range
Average() = returns the average value of the cells selected in a range



Let’s continue working on the table we created earlier and let’s add three formulas
 

In H4 write Total Quantity
In cell I4 type Total Revenue
In H5 write =sum(E4:E10)
In I5 type =sum(F4:F10)

 

 
You can also manually select the range of cells once you have opened the brackets in the formula
and then close it and press enter
 

In J4 type Average Revenue
In J5 type =Average(F4:F10) (or select the range with the cursor once the bracket is open)
Now, the table should be as follows
 

 



Formatting text – Underline and Italic
Select the 4 cells with the headers you have just created
✂   SHORTCUT (Underline): Press CTRL + S (Press again to remove)
✂   SHORTCUT (Italic): Press CTRL + I (Press again to remove)
You can obtain the same output by selecting the cells and pressing on the icons I and U in the
Ribbon above the formula bar.
 



 
Editing the worksheet
Insert, Delete, Hide
Insert column(s)
Select column B by clicking on the B Header
✂   SHORTCUT: Press CTRL + SHIFT + +
⏱   MANUAL: Right click on column B header > Insert
If you select multiple columns, step 2 will add the same number of columns selected
For instance, if you select 3 columns and insert, you will insert 3 new columns.

 
Delete Column(s)
Select column B by clicking on the B header
✂   SHORTCUT: Press CTRL + SHIFT + -
⏱   MANUAL: Right click on column B header > Delete
If you select multiple columns, step 2 will delete them
 
Hide Column(s)
Select column D by clicking on the D header
✂   SHORTCUT: Press CTRL + 0
⏱   MANUAL: Right click > Hide
If you select multiple columns, step 2 will hide them
 
Unhide Column(s)
Select column D by clicking on the D header
✂   SHORTCUT: Press CTRL + SHIFT + )
⏱   MANUAL: Right click > Unhide
If you select multiple columns, step 2 will unhide them



 
The same principles apply to Rows
Add Row(s) - ✂   SHORTCUT: CTRL + SHIFT + +
Delete Row(s) - ✂   SHORTCUT: CTRL + -
Hide Row(s) - ✂   SHORTCUT: CTRL + 9
Unhide Row(s) - ✂   SHORTCUT: CTRL + SHIFT + (

In this example, we selected 2 columns (B and C) > right click > insert. We now have two new
empty columns and the rest of the columns in between have been moved to the right.
 

 
So far, we have seen how to add / remove / hide / unhide entire rows and columns. 
What if you wanted to edit the table only, without changing the rest of the Worksheet?
Simply select the data range you want, right click, insert, delete or chose among other options as
needed.
 

 
You can remove the selected cells by clicking on the most appropriate option (in this instance,
shift cells to left will revert the table to our original configuration). The main difference between
removing columns and removing cells, is that sometimes you only want to edit a specific range



of cells and let the rest of the column unchanged. In this case, you will only remove a range of
cells you select, leaving the cells above and below untouched.
 
Let’s continue with the following

Click CTRL + A to select the entire sheet
Change the background color to No Fill
click CTRL + SHIFT + L to remove filters
Select the entire table
CTRL + X to cut
CTRL + V to paste it in Cell A1 (we cut-pasted the table in A1)

 
Now let’s add a few more values to the table. As you can see, we have 7 clients, that purchased 2
different types of items in different quantities.
 
��  We want to double that, but keeping clients and items to 7 and 2.
 

Copy all the table values (don’t copy the headers) and paste them in the first empty cell
below (A9)

 
We have now duplicated the cells and doubled values for each client.
If we received this data set (or a larger one), we wouldn’t be able to tell, at a glance, how many
items of the first type each customer has ordered, or the revenue associated to each item across
all 7 customers.
In order to analyse this data better and faster, we will have to use one of the most important
concepts of Excel: Pivot Tables
 



 
In this section, you learnt how to use shortcuts and commands to clean your spreadsheet,
improve formatting, maximise clarity and visibility, add formulas, toggle filters and other ways
to manipulate the spreadsheets before starting to work on your data. Keep practicing, get familiar
with selection, drag & release, copy-paste, undo-redo, inserting, deleting, hiding and fitting
columns, and soon you will be able to do exactly what you need to do, when you need to do it.
In the next section, we will learn about another fundamental topic in Excel, which will allow you
to massively speed up your work, especially when managing large data sets.
Get ready to become a master at using Pivot Tables.
 



Chapter 5: Pivot Tables
 



Pivot Tables
Pivot Tables are an absolute must know when it comes to Excel. They allow you to transform a
dataset into a table, analyse data, use filters, create charts, interactive dashboards and much more.
Pivot Tables are a powerful tool that can automatically count, sort, calculate and summarise data
for you. They have pros and cons, they can be very useful, but they are not intuitive and, if you
don’t master them, they can slow your work down and you will waste time.
We are now going to look at Pivot Table to understand the basics, how they function, and see
multiple strategies to help you use them at your advantage and save hours of work every time.
 



Transform your dataset into a table
Every Pivot Table is linked to a data source. Every time your data source change (in this
instance, our table with 7 customer records), you will have to manually REFRESH the pivot
tables linked to it or CHANGE DATASOURCE, in the event your new data has more records
or you simply want to place the data source in another sheet.
Imagining that next week we will have new data, we want to optimise all the work that we are
going to do now with the Pivot Tables, as doing it every week from scratch will be too time-
consuming (I will show you how to create pivot tables fast and handy strategies to go even faster,
but the reality is that these procedures are not very fast, so you want to get the most out of the
Excel automation capabilities and plan ahead, knowing you are building Pivot Table to automate
a process over the weeks)
 
Transform your data set into a table
Select the entire table
✂   SHORTCUT: Click CTRL + T
Your selected data is highlighted in the data range box. Don’t edit it. Just make sure all the data
in your table is selected properly. Press Enter to confirm

You can get the same outcome by selecting the table and press from the Ribbon
Home > Format as a Table
 



One you format your data set as a table, you will see that the look of your data set changes.
You can click anywhere in the table at any time and you will notice that a new section named
Table has been added to the Ribbon. From this section, you are able to change the table settings,
select or create a style, change rows and columns and much more.
 

QUESTION: Why do you need format my data as a table before creating a Pivot Table?
ANSWER: To automate the process. In fact, you are now going to select your table to create a
Pivot Table. Which is different than creating a Pivot Table from a simple data range.
The problem is that all the pivots you are going to create will get the data from the range
A1:E15, which is the current range of your table.
But what if tomorrow the range is A1:E16, with a new row added to the bottom?



The Pivot Tables you have created today will not automatically update, and you will have to
manually update them all with the new data source to see the updates in the Pivots.
But if you transform your data into a table BEFORE creating a Pivot Table, you will never have
this problem, and the Pivot Table will get the range updates automatically as your data changes.
Multiply this for all the data sets you will analyse, all the pivot tables you will create, and all the
times you will have to update every table. It’s an incredible amount of time, and a lot of manual
work.
This simple process, will save you all that time!
Now, you can even add a new row manually on the bottom and you will notice that it will
become part of the table automatically.
 



Create a Pivot Table
1. Click anywhere in the Table
2. From the ribbon, click on Insert > Pivot Table
3. Press OK to confirm the creation of a Pivot Table in a new Worksheet (here named Sheet

2, it follows the number of the previous sheet)
 

 
You can also add the pivot table to the current worksheet or CTRL + X, CTRL + V everything
later, therefore I suggest to always create the Pivot Table in a new sheet.
As you can see a new sheet has been created
 

 
The new sheet has also 2 new sections in the Ribbon that will appear when you click on the Pivot
Table. These sections are named Pivot Table Analyse and Design. You can already see the two
buttons REFRESH and CHANGE DATA SOURCE we mentioned earlier.
You will need to refresh your data from the pivot if you update Sheet 1, but not to change the
datasource, if you will keep updating it in Sheet 1 over the weeks.
 



     

 
You may also notice the field list in the right side of the screen and 4 boxes (Filters, Columns,
Rows, Values) that you will use to change your Pivot Table by dragging and dropping the fields.
✏   NOTE: if you create two distinct pivot tables, you can click on each of them individually to
access the linked field list and edit the table, one at a time.
✏   NOTE: This is the field list. It will appear when you click on the pivot table, it will disappear
once you click out. If, for some reasons, you cannot see it anymore despite you are selecting the
Pivot Table

1. Click anywhere in the pivot table
2. From the Ribbon, Select Pivot Table Analyse



3. Click on Field List
 
Et voila’! The Field List should have now re-appeared.
 

 
Now, let’s start creating the table by dragging and dropping fields in the boxes.
 

1.    Drag & drop Client ID in Row
2.    Drag & drop Quantity in Values
3.    Drag & drop Price in Values
4.    Drag & drop Revenue in Values

 

 
This starts to look like the table we have created at the beginning, but now the data is aggregated.
Remember when we duplicated the table and pasted the values on the bottom?
This pivot table has all the customer values, but added up and summarised.
 
As soon as you drag & drop your fields, you will notice the following

the numbers are not formatted
the fields appear with a Sum of before the name.
looking at the values in the Values Box, we can see that they are all marked as “Sum”
Something off in the Price column. The prices are higher than they should be, and so the
sum of all the prices in the total column.
 

Let’s start by formatting the values in Quantity. We want them to be in scientific format.
Contrarily to what we have previously done with formatting, with shortcuts or commands from



the ribbon, we can’t format Pivot Tables the fast way.
This is because if we do so, when we update the data and REFRESH PIVOT TABLE, we will
lose all the formatting and we will have to do it from scratch!
So, one of the ways to avoid it is simply clicking on the i icon near the data field and select the
format from there.
 
 



Other quick ways to do it are
 

1.    right click on the data > Number Format
2.    right click on the data > Value Field Settings

 
 

3.    Click on the data > Ribbon Pivot Table Analyse > Field Settings

 
You can select “number”, add 1,000 comma separator and select 0 decimals.



 
As regards Count, it will display the count of the items (in this instance =7, which is the number
of rows in the Pivot Table). Generally, Sum is the most used, that’s why it is in most cases the
default option.
This doesn’t always work. As mentioned, we can see that Pricing is off. This is because the
pivot is calculating this metric as a sum of values, but the prices don’t double with the number
of items sold or the number of customers. We don’t need a sum operator for this field and we
need to amend it manually.
So, we will select Average. The Pivot will calculate the Average Price, and as the each item has
its own price, they will now be displayed correctly.
Now, format Revenue and select $ (US dollar) from the currency dropdown list.
Click on the data > Ribbon Pivot Table Analyse > Field Settings
The Pivot Table is now formatted.
 

 



Now, we will change the headers name in bulk.
✂   SHORTCUT: Click on CTRL + A to select all values in Sheet 2
✂   SHORTCUT: Click on CTRL + H to display the Find and Replace Icon (or click on the
Magnifying Glass Icon on the top right part of the ribbon, where you can see Find & Select)

Find “Sum of ” (with empty space at the end)
Replace with “ ” (empty space)
Given the way Excel is coded, if you don’t replace the value with a space or some other
character, an error message may appear to warn you that the name you are trying to create
already exists, so you are not able to make this change in the name. But you need to change the
header value and eliminate the “Sum of” and “Average of” from the header to get a clear
readable table.
You can then avoid this problem by adding an empty space, an underscore or anything you want.
Do the same thing with Average. CTRL + H > Find Average of > Replace with (empty space)
 
Now, select Row labels and type over CUSTOMERS
 
Move Pivot Table to the top of the sheet (cut and paste)
Select the entire Table
✂   SHORTCUT: CTRL + X to cut

Move the table to B2. You will have to face a little challenge. You will be able to solve it even if
you have never seen it before. The challenge is that it won’t allow you to cut-paste a pivot table
overwriting another, but your goal is to cut-paste the pivot table in B2. Once done:
 
Duplicate Pivot Table (Create the second Pivot Table with copy and paste)
Select the entire Table
✂   SHORTCUT: CTRL + C to copy



✂   SHORTCUT: CTRL + V to paste a copy right below in B13
 
Replace Row Labels in the copied table with ITEM just by typing over it. You should be in this
scenario.

From the new pivot table (ITEM), go to the field list on the right.
From the field list, drag Item into the Row Box underneath client.

           
 
You have now a breakdown of quantity and revenue for each Client and Item.



You can swap Client ID and Item within the Row box to see how the table changes
 

        
 
You can also collapse or show the fields within the Pivot Table with one click to show or reveal
the data as you need (click on the + / - sign near Blue Shirt and Red Shirt.
✏   NOTE: You can filter a table by adding a field in filter (as we will show in the next chapter),
swap rows and columns, and add multiple columns in the field box.
Now take Customer ID from the new table and drag it back to the field list
You have now two tables, one with Customer ID in the rows and one with Items in the rows.



 
✏   NOTE: we have done number formatting BEFORE copy-pasting the tables and change
values.
This way, I avoided creating 2 Pivot Tables from scratch and have to manually do the
formatting in each column. This is a crucial step if you have a lot of tables to do, a lot of
data to format and you want to avoid wasting time in formatting activities. This is a process
strategy and approach that allows you to identify the most time-consuming tasks and just
carry them out in the process when it’s most convenient.

Show Values As
Now, go to the Customer ID table, and Right-click on the Quantity column.
You will be able to see the option: “show values as” and you can select “% of grand total”.
You can see how now the numerical values have changed to percentages of the total, called
“Grand Total” so you can better understand how much in % each client purchased compared to
the total.
As you can see, with Right-click on the column you have a lot of different options and you are
invited to test them and play around until you get more familiar with the app interface
 

       



We have previously seen how to create formulas in cells, now let’s have a look at how we can
create formulas within the Pivot Tables. 

1. Select the Pivot Table with Customer ID on the rows.
2. On the Ribbon, click “Pivot Table Analyse”
3. Click on Fields, Items and Sets
4. Click on Calculated Field

 

 
Calculated field is the name of formulas created within the Pivot Tables.
Let’s suppose that each 2 ITEMS were combined in a PACKAGE, and we want to calculate how
many packages we have sold. So, we will create a formula Packages = Quantity/2
✏   NOTE: you can create formulas before in the process as well, so you will add them to the
first table, format them, and then you duplicate the table and edit it. As we are creating the
formula now, if we want to add it to both tables, we will have to format it twice, once per table.
 



 
Type in the following formula, and click OK to confirm. As we have done for the previous
fields, we can double click on the i icon to change the formatting style and the decimal points.
 

 
Our new calculated field has been added to the list, and we can now drag and drop it in any table
we want.
If we want to edit the calculated field, we just need to click on

1. Click on the Pivot Table
2. On the Ribbon, click Pivot Table Analyse > Calculated Fields
3. Click the down arrow to reveal your field
4. Edit your calculated field and confirm

 



         

As mentioned, not everything will work as a calculated field formula and may give you some
trouble, like costs and percent values, which are often tricky and needs to be calculated manually
with formulas without the use of pivot table. You need to make sure you select the data you want
in the table, select the operator (sum, count, average…) and double check it’s working properly.
If not, you may have to use create formulas or apply edits to your original file, to make sure it’s
ready to be used as a Pivot Table data source file. Another workaround would be to create
standard formulas near the pivot table in the spreadsheet, using values from the pivot
table, but outside the pivot table (it sounds complicated, but it’s actually very simple: basically
you will create a table and add formulas near the table, so it will look like it’s a big unique table,
when instead is partly a pivot table and partly just a normal table with formulas).
Pivot tables are very useful and powerful. you can use them in several scenarios to speed up your
work:
data summarisation, report creation, list the unique values of any column, filter, analyze, sort,



data without writing a formula or a macro, make dynamic pivot charts (as we will see in the next
chapter, transpose data (i.e. switch columns and vice versa, show breakdowns)
 
To create Pivot Tables

Format your dataset in Table format
Insert Pivot Table from dataset
Add fields
Format Fields
Create Formulas (Calculated Fields)
Add multiple rows, swap rows
Use filters
Change how you display values in pivot table
Duplicate tables and edit when it’s most convenient (e.g., post formatting)



Chapter 6: Pivot Charts
 
Charts are another of the fundamentals of Microsoft Excel. Nevertheless, creating and
customising charts can still to these days pretty time-consuming in Excel. It’s the price to pay for
the very high level of customisation. I will show the basics and more to become a pro and create
outstanding charts fast. The first thing you need to know is that, the same way formulas and
calculated fields are not exactly the same, charts and pivot charts are not the same either.
And while they have a lot of similarities, the way you build and edit them is slightly different.
Personally, I prefer to create charts from a normal table than a pivot table, as it’s a bit faster
and doesn’t give as many formatting issues as creating charts from a pivot table. But for now, we
are going to start from Pivot Charts, and specifically from charts created from simple Pivot
Tables like the ones in this example
 

1. Click on the ITEM Pivot Table
2. From the Ribbon > Insert > click on the bar chart > select the first Bar Chart

 
A bar chart with 3 data series will be created from the table you selected.
DATA SERIES: a column with data displayed in a chart is called Data Series.



You can also obtain the same output if you
1. Click on the pivot table
2. From the Ribbon: Pivot Table Analyse > Pivot Chart
3. From the Ribbon: Design > change chart type

 

 

 
 



Customise Pivot Charts
I will now show you the basics of chart customisation, extremely important for reporting &
dashboards

1. You can click on the graph and move it around

2. You can click on the graph border or corner and resize it (hold SHIFT to resize it while
maintaining proportions)

     
3. You can click on the legend, the X-axis or the Y-axis and add bold formatting, increase or

decrease the character size (using the buttons A ��  A �� )

 



 
You may have noticed that when you click on the chart, the Ribbon has changed as well.
You now have “Format”, near “Design” and “Pivot Table Analyse”.
These sections will allow you to customise the chart look and the chart data.
 

1. Right click on the data series
2. Click on format data series

 

Our goal will be to get to a final result as the following, which is much clearer and user-friendly.



This is quite a time-consuming process, but learning how to create slides and presentations
through Excel is a must have skill for professionals.
When it comes to analysing data, being able to present them in a clear way to clients and
stakeholders is a key part of the process. Therefore, the ability to create high quality charts in
your presentation is an absolute must within your data analytics process.
But the good news is that I will show you exactly the best strategies to improve your chart, the
fastest way possible and how to optimise your work.

PRO: it allows a lot of different customisation options and it’s very flexible
CON: obtaining high quality design is time consuming and there are not a lot of user-friendly
templates to create beautiful visualisations, therefore you will have to do quite some manual
work even if you start with a template.
If if you click on a data series and then try to change colors or use one of the Excel templates,
you will be quick to realise that the app is definitely not optimised for presentation. The default
color palettes look pretty vintage, so as the chart types you can select from within the Design tab
in the Ribbon (for instance, in the below chart, the labels have been added automatically, but as
you can see they would need to be improved with manual work – color – size – position…).
 



 
On the right, a new section “format data series” should appear near the Pivot Field list.
 

You can use this section to
1. Change the axis of the selected series, in order to improve the chart
2. Change the series overlap, which is how the series selected will overlap with one another
3. Change the gap width (increase or decrease) between series

The Format Data Series section has 3 subsections. One for axis (1), one for shadows and effects
(2), one for fill and border color. We will cover section 1 and 3, which will be more than enough
to create beautiful charts and we will let you explore the shadow section (which is not among the
most important things to know when it comes to charts in my opinion: I always use a clean
minimal style for my charts. 
You can’t go wrong with it, and it will never go out of style)
 
Section 1 Section 2         Section 3



  
 
Select the following parameters for the first data series.

 
And you will get the results as in the picture below. If you have multiple bars in the same chart,
you will have to play around with this tab for each of the series, in order to find the best
configuration.
In fact, some versions of Excel make even the simple process of having multiple bars in a chart
quite tricky. The bars may overlap and you will have to manage this process manually.
 



 
We have already done the exercise and we will tell you the final numbers. We will also show
you the difference between Pivot Charts and Charts later in the chapter.

✏   NOTE: if you are struggling with series overlapping, try to reduce the number of bars per
chart or switch to line chart or area chart, where you won’t have overlapping issues.
Select the 3 series, one at a time, and write the parameters as below.

 
The second section has a paintbrush symbol. Within this section, you will be able to customise
fill an



d border and improve the look of your chart



In this example, you can change, for both series
1. The border color
2. The border width (e.g. 1.75 points)
3. The background color, by selecting Solid Fill
4. The background transparency (60%)

Select one series at a time. Under fill add 60% transparency
 

 
Under border, change the color to black and add 1.5 points
 

 
Repeat the same process for each of the series and you will have this result (you can change the
colors as you prefer) and this is going to be your final result.



 
When we create a chart from Excel, the starting point is pretty basic and messy at times, but just
by changing axis, colors and transparency, you can easily create pretty, minimal charts in no
time.
Let’s resize the chart. Put the cursor on the vertical right side, hold and drag to the right.
You can also click on one of the corners, hold SHIFT and drag to increase size without changing
the proportions. The same chart can look very different, so you need to find the best size,
proportions, and how to place them in your spreadsheet with other charts and text.



 
✏   NOTE: the basics of charts are creating simple charts, even with no border or transparency,
just nice clean consistent colors, the right proportions, and making sure they are simple and
readable. Master the basics of design and make sure you adjust and prepare for the person that
will look at charts and tables, small details can make a big difference in client communication,
possibly more than you may think.
 



Let’s add a title to the chart.
Click on the chart area or border (not on the series)
On the top left corner of the Ribbon, under Pivot Chart Analyse > Design > Add Chart
Element
Select Chart Title > Above Chart

Double click on the title to edit. Use the formatting options in the Home tab as usual

 
Now let’s place the legend below the chart. To do so, right click on the legend > Format Legend



The panel on the right side will now show the customisation options for the legend, split in 3
sections.
Click on Bottom to place the legend on the bottom

Let’s add the labels. Right-click on a data series > Add Data Labels



Once you add data labels to all the series you need, you can double click on the labels and
customise them within the Home Tab, as usual

Or within the Panel on the right side of the screen, where the panel will have a data label section.



You can drag & drop Price in the Row Box (Field List), to get your new metrics automatically
added to the pivot chart. The same way you can remove fields from the Pivot Table to get it
reflected in the Pivot Chart.
Let’s remove Quantity from the table

We can untick it from the field list
Or we can drag it back from the Values box to the field list

 
One of the reasons why it’s preferable to create charts from data and not Pivot Charts, is that
every time you drag and drop fields in an out of the field list you may lose some formatting
settings both in the Pivot Table and in the Pivot Chart. This is how they will look like after we
remove Quantity.
As you can see the background color where there was the quantity column went from white to
No Fill, and we also lost one axis in the Pivot Chart



You are going to learn how to avoid this type of problem, but for now, let’s recap the entire
process that we learnt so far:
 
RECAP

1. Get a data set
2. Transform it into table format by selecting it and use the shortcut CTRL + T
3. Click anywhere in the table and select > Insert > Pivot Table
4. Drag & drop the fields from the field list to the boxes on the right side of the screen
5. Format numbers, add calculated fields, change “show” as if needed
6. Right click on a column in the Pivot > Show value as if you need to change it
7. Click on the Pivot Table > Insert > Chart
8. Customise the chart through the formatting options in the Ribbon (Pivot Table Analyse,

Format, Design) or double click on the data to open these options
9. Add or remove fields in the Pivot Table to edit the linked Pivot Chart automatically

 
✏   NOTE: Pivot Chart work best when the table has one, two or maximum three values. It’s just
easier to manage changes and visualise data. You can definitely add more, but the more you add,
the more the chart may be difficult to read, and the less the Pivot Charts will become flexible. So,
while you may be working on a chart to simplify the visualisation, you may end up having some
issues in customising the chart and keeping it looking clean. So, keep it simple. Start from the
basics.
Now, let’s take the Pivot Table “Item” and let’s add Customer ID in the related Filter Box.
You can now filter the Pivot Table and the Pivot Chart just by selecting items on the filter.
You can add as many filters as you want in order to dig deep in your data as you need.
 



 

 



Interactive Dashboards
We are now going to learn a super-handy command that will allow you to analyse your data in
no time.
We will create interactive filters to change the chart and the table interactively.
Click on the “Item” Pivot Table and click from the Ribbon: Pivot Table > Insert Slicers.
From there, click on Customer ID to insert it.

   
 
The slicer is an interactive filter that will allow you filter the table (and all the tables you will
link to the filter) with one click. You can add as many slicers as you want and use them in
combination.
The main goal of this will be to create a dashboard with tables and charts, add the filters, and
being able to sort through the tables and charts in a few clicks.
Now that you have added a slicer, just place it on the right.
If you click on any client within the slicer, you will see the Pivot Table and the Pivot Chart
changing in real time. But the second table is not changing.



This is because you have to connect it to the filter to the table.
✏   NOTE: You can create a slicer from a Pivot Table, but if you have more than one Pivot
Table, you have to manually connect / disconnect each slicer from the table.

1. Right click on the slicer
2. Click on Report Connection
3. Tick the second pivot table

 
Now you can analyse both the tables with one click.
You have just created your first basic interactive dashboard. The Pivot Table with Customer is
now changing based on the options selected in the filter, so as the Pivot Table with Item and the



linked Pivot Chart.
 

 
As previously mentioned, an important aspect of the Pivot Tables, consists of automating the
process and creating a re-usable structure that you can update over time and see the data changes
without having to do everything from scratch.
This process has to be done carefully though, as any small error in the procedure will prevent
you from going forward and, let/s be honest: Excel error messages and troubleshooting
procedures are not the most user-friendly, so we will now cover the fundamental steps you need
to take to ensure you can re-use your templates over time without spending too much time fixing
data issues.
Add another slicer, move the table and the charts around to improve your dashboard.
 

 
So far, we have built

1. A data source in table format
2. A Pivot Table
3. A Pivot Chart
4. Slicers to filter the table
5. An interactive dashboard with multiple tables, slicer and a chart

 



Let’s assume that we are now in week 2 and we need to update our data source (Sheet 1) and get
our tables and charts ready to analyse the weekly data.
Let’s assume that we have two new customers, here named Customers 8 and Customers 9.
 

 
1. First, if you have created slicers, you have to manually disconnect them from all tables

otherwise the REFRESH data procedure will not work, and the data will not be updated
neither in the pivot and in the chart (each slicer has to be disconnected from all the tables)

2. You can copy-paste the new data in Sheet 1. This is the new data source you have to
analyse

3. Normally, you would have to select the pivot table > from the ribbon > pivot table analyse
> CHANGE DATA SOURCE > manually select the data source in Sheet 1, ensuring the
new pivot table range covers the entire data set, as the data in week 2 may contain more
records than week 1. But, as we formatted our dataset as a table BEFORE creating the
Pivot Table, we can skip this procedure. Normally, you would have to click on every
pivot table, right click > change data source > go to Sheet 1 and select the data source for
each table

4. Click on a Pivot Table > from the ribbon > Pivot table analyse > REFRESH
 

 
5. Re-connect all the slicers (Report Connection > thick the tables one by one)

Notice how the chart and the tables have been updated in a few clicks.
 



✏   NOTE: you have to disconnect the slicers (Slicer > Report Connection) before refreshing the
data
✏   NOTE: formatting your data set into a table with CTRL + T before creating the pivot table
will avoid you manually changing data sources to all your Pivot Tables.
 
So, to recap:
The pivot tables are dynamic tables connected to a data source. When you update the data
source, you need to change the data source within the pivot, unless you format your data source
as a table first. You then need to REFRESH the pivot table so they will read and show the
updated data. If you have added slicers to create an interactive dashboard, you need to disconnect
them, REFRESH, and reconnect them.
Important: when you create a Pivot Table from a data source, ensure the data source has

no empty columns / rows
no total / subtotal rows
each column has to have a header

 
We will talk more about this when you will learn about data cleaning, where you will learn how
to clean your raw data file before starting to work.
 



Pivot Tables Tips & Tricks
 
Subtotals
If you click on the Ribbon > Pivot Table > Design, you can hide and show totals / subtotals,
change the tables styles or create a new style.

    

 
The pre-made styles are not the most modern design you would find, and customising tables in
general is not fast and easy, on the contrary the colors are standard and not very modern, but you
do can create beautiful visualisaton, with a simple, modern style.
Also, I will show you a trick to access to better colors in seconds.

Subtotals – Understand how to summarize your data
As previously pointed out, we can see that one of the fields we added (price) is giving us
problems when it comes to totals. In fact, the prices we input at the beginning are from $20 to



$40, but if we look at the totals in the Pivot Table we can see $144, which is the SUM of all the
prices.
But, when it comes to Prices, you don’t want the total price value displayed as the sum of all the
prices, and you don’t want to leave it there as it’s not the correct number.
In this case, you can hide all the totals and manually recreate all the formulas manually or you
can simply select the total price cell, and change the font color to white (or to any other color to
make it disappear in the background). You can’t manually edit any number in a pivot table, that’s
why you need to become a bit creative and find out workarounds when some issues with the
pivot structure cannot be easily solved.
 

 
Filters
We have covered early how you can filter tables by adding filters and play around with the
options, how we can filter pivot tables by dragging and dropping a filter in the Pivot Boxes, and
filter the interactive dashboard with slicers. We will now look at another way to filter through
data (it works with standard tables and pivot tables)
Click on the filter arrow in customer ID table, click on Filter by value > Less than > input a value
and press OK.



You have now filtered the table and added a minimum value.
You can also do it from fields you added in the field list > filter
 
��  Undo action with CTRL + Z.
 
When you have a large data set to manage, you can start analysing it by simply

sorting the columns
filtering the columns

 
These 2 simple tasks combined in different order, will allow you to have an immediate first fast
understanding of your data before starting. 
You can see through the data, looking at the unique values for each column in the filter box, you
can sort data in ascending or descending order, by color, or adding conditions.
You can also filter one column and dig deep in your data by analysing the other columns



Conditional Formatting
Conditional Formatting is another very handy Excel feature, it allows you to select any data table
and highlight specific cells that meet certain conditions.
So, for instance, if you have a large data set you may want to highlight only the cells where
Revenue is above a certain value. Or maybe you want to highlight the top 10% cells with the
highest revenue, bottom 10% with the lowest margin, or specific cells that include string values.
Conditional formatting allows you to do all of this and more.

1. Select the data range you want to apply conditional formatting to
2. Click on Conditional Formatting on the ribbon (right side in the Home tab)

 

 
You can highlight cells that contain duplicate values, a specific value, or highlight cells that meet
specific criteria, such as greater than, lower than, equal to a specific number, top or bottom
values, and even add data bars.
Select the column Quantity
Click on Conditional Formatting > highlight cell rules > above average
 

 
Select the green style or create a new style (the default red color for conditional formatting is
very flashy and red it’s generally associated with errors, that’s why we need to change it for a
better data representation).



Now select the Revenue column (excluding headers and totals) and click on
Conditional Formatting > Data Bars > Solid Fill

You now have bars within the table and have also a better data visualisation.

Click on Conditional Formatting > Manage Rules > select the bar rule > change the color to
purple > add max value equal to 0.5 and press enter to reduce the distance between the bar and
the right border of the cell.
Now select the entire table > Conditional Formatting > Clear Rule > clear rule from the selected
cells to remove any formatting.



 

 
Et voila’!

Conditional formatting is a very important tool that allows you to format cells based on specific
conditions. This allows you to get insights on your data at a glance and get real time
information as your data change, but your formatting rules remain unchanged.
Once you format cells and add colors, you will also be able to filter them by color when
accessing to the filters.
 



Standard charts vs pivot charts
Let’s create a standard chart by duplicating a pivot table. Select the CUSTOMERS Pivot Table.
✂   SHORTCUT: CTRL + C
✂   SHORTCUT: CTRL + V
 

Click on the notepad icon on the bottom left and select Values & Number Formatting
 

 
You have just copy pasted the same table, but only the values and the formatting (number,
currency). This is now a standard table with formatted numbers, the same as the one you had
created at the beginning and the same format you will get when you will receive a data source.



If we want to be a little bit more advanced, let’s use a simple formula to do something different.
Let’s copy the table linking the cells using the simplest Excel formula. By doing so, we will be
able to manipulate the Pivot Table while creating charts from a non-Pivot Table, that on top of
that will adapt in real time.
 

 
Apply bold formatting to the headers
Select the headers in the table
✂   SHORTCUT: CTRL + B
Add outside borders to the table
Select the full table
✂   SHORTCUT: CTRL + Shift + &
Format currency
Select data
✂   SHORTCUT (Dollar): CTRL + Shift + $
✂   SHORTCUT (Number): CTRL + Shift + 1

 
Test Slicers on the Pivot Table, and see how the new table changes as well accordingly
 



Untick the slicers
Select the first 3 columns of the second table – Normal Table (Customers, Quality, Price)
Ribbon > Insert tab
Click on the chart Icon

(creating charts from standard tables > select the data source manually and insert chart)

 



Difference between creating Standard Charts and creating Pivot Charts
 
PIVOT CHART: click anywhere in the Pivot Table.
A chart is created with ALL THE fields in the Pivot Table.
Formatting, adding and removing fields from the Pivot Table is time consuming
CHART: select the data you want and create a chart.
You can now work on a new standard table.
 
Insert the chart and start editing the series. This time, you can create one bar series and one line
series.
Right click on the line > format data series > you will have different options such as Marker (you
can see the marker selected in the line chart)

 
You can click on a data series in the chart and see what data is linked to
 

Click and hold the border of the selection box to drag them. Hold on the corners to change them.
You can drag the range once you Hover over one of the sides of the range



In case you notice something off on your chart, click on the data series one at a time and check
what data they are connected to. Also, ensure you don’t select the totals, or they will appear in
the chart.
Check out how the chart changes as I drag the source of Revenue in the wrong place)
 

If you need to edit your chart, you can do it the following ways, same as for the Pivot Chart (with
some differences)
 

From the Ribbon > Chart Design > Format
 

 
From the formatting panel on the right
✏   NOTE: based on where you click in the chart, a different formatting panel will open
to allow you the customisation on different items



Right click on the legend, the axis, the labels
 

Right click on gridlines



Right click on a series
Right click on the chart borders for other options

 
 
Let’s recap what we learnt

1. Select data from a normal table
2. Insert chart
3. Customise series
4. Ways to customise series
5. Pros and Cons of Pivot Charts
6. How to create a table = to a Pivot Chart
7. How to flexibly change data

 
Change colors
This trick works for the color panel and will therefore work with charts, pivot charts, tables and



normal cells. Ribbon > Page Layout > Themes
 

 
 



You can select one of the available themes
 

 
When you go back to the Home Tab in the ribbon and open the color panel, the colors have
changed and you can now choose among better color combinations than the default one

Once you create and customise all your tables and charts, changing the color template will
automatically reflect on everything you created.
Pivot Charts and standard charts are almost identical. One of the main differences is that standard
charts are linked directly to cells in the worksheet, while Pivot Charts are linked to a PivotTable
data source. Unlike a standard chart, in Pivot Charts you cannot change the data range in the
dialog box, so you can use the workarounds you just learnt to setup your tables in the smartest,
leanest way possible.



Chapter 7: Data Cleaning
 



What is Data Cleaning and why it is important
So far, we have learnt a lot of the Excel fundamentals and laid down solid foundations to build
up new knowledge and keep improving your skills.

1. We have learnt the basic ways to navigate a Worksheet
2. We built a simple table
3. We created Pivot Tables
4. We created Pivot Charts
5. We created a simple interactive dashboard
6. We learnt how to customise colors and design for charts and tables
7. We learnt how to format cells based on conditions

 
Now we will take a step back, and instead of building a simple table like in point 2, we will start
from a large data set and simulate a real work scenario, where we receive a data set, we navigate
through it and we notice that we have to clean the data. Only afterwards we can start analysing it
and apply the techniques we learnt.
 
The data cleaning process includes a set of actions you need to perform on raw data before you
are able to start analysing it through tables and charts.
Why do the data need to be cleaned? There are many reasons behind it, but the main explanation
is that data cleaning is related to the data collection process. Depending on how the data has been
collected by the person or the machine giving you the data set, you will have to apply a set of
technique to harmonize the dataset and get it ready. Excel has 5 main ways to help you do that
 
Excel data cleaning processes

1. Text to column
2. Flash Fill
3. Formulas
4. Remove Duplicates
5. Power Query

 



Text to Column
Text to column is one of the most important commands when it comes to data cleaning. It works
when you have a scenario like the below, where all the elements in a column have a structure
where they are separated by the same separator. This examples often comes up in online
advertising, where your campaign, ad set and ads may include a lot of information, separated by
a hyphen (-) or an underscore (_) or similar. Let’s see a simple example with Customer Name.
As you can see, we are receiving all the names in the format Name_Surname, and we want to
split them in 2 separate columns.

 
All you have to do is

select the column
from the Ribbon click Data > Text to column

 

Select the separator > press Enter
The separator is that repeated element in your name that you want to use as “split point”.
Your name will be split and new columns will be created (n= number of separators in the name
-1).



Understanding this concept also allows you to understand how to structure your data during the
collection process. Ensuring you plan ahead and decide an effective naming convention, will
allow you to clean your data faster and get better insights in less time.
As mentioned, an example when Text to Column is required can be an Online Advertising
Campaign. The name of your adverts could follow the following naming convention:
Campaign Name_Campaign Goal_Country_Age_Gender_Targeting_Creative_Ad Copy
Black Friday_Traffic_USA_18-44_M + F_Baby Boomers_Smiling Woman_Copy 3
So. when you export your data, a simple text to column will create 9 different columns, which
will give you 9 new dimensions and table filters instantly.
 

     
 
 

as new columns will be created on the right, ensure you don’t have data within the column
on the right create enough space adding new empty columns (using the shortcuts you
learnt in the previous chapters) so you will avoid data overwriting.
Add Row(s) – Select Row(s) in the middle of the data set 
✂   SHORTCUT: CTRL + SHIFT + +

Swipe through the new data to ensure everything is in place and manually adjust any
potential error derived by inconsistency when naming the items.



Now you can:
Quickly format as a table ✂   SHORTCUT: CTRL + T
Click on Filters. You have just created a new dimension to analyse the data

 
 
 

You can split the columns by fixed width as well, this would work well for instance if you
had a column with cars’ licence plates. In this instance, it would be difficult for you to
find a separator that all the cells in the column share, but you can easily split the columns
by fixed width (e.g., separate the first 2 numbers from the rest of the values in the string)

 

And get to a final result, as follows
 



You will have to manually input the column headers, unless you can successfully apply text to
column to the header as well.



Flash Fill
Flash fill is a powerful Excel command that you can use when you want to automatically
complete a sequence and fill the cells below with one click.
It corresponds to the “Drag cell” we have analysed earlier or to the “double click on the cell
anchor point” to complete a sequence following a pattern.
Let’s suppose you have a list of people with name and surname.
Go the first empty cell on the right and start inputting the first name in the first cell.
Excel will recognize the pattern and will give you the opportunity to flash fill by pressing enter

-          Press Enter to accept flash fill
-          ✂   SHORTCUT: Press CTLR + E to flash fill

Excel recognizes the pattern will apply flash-fill on the entire column, up to the bottom of the
table.

Flash fill is a static option. It means that if the original cells changes, the flash filled cells will
not. 
You will have to manually update them and repeat flash fill. We will discover later how to fill
cells dynamically through formulas.
 



Remove Duplicates
The remove duplicates function allows you to remove identical rows and avoid issues related to
multiple record entry with the same values. So, you avoid counting the same data twice.
The duplicate rows that share 6 values are highlighted in grey.

Just select the data set, then click on
From the Ribbon > Data > Remove duplicates

 

 
You can select which values (by columns) will have to be identical between 2 rows so one
of the rows can be deleted as it will be considered as duplicate
Press Ok
A popup message will tell you how many rows have been removed from the original data
set

 



 
✏   NOTE: those processes are all manual and they need to be re-done every time you have a
new data set, unless you want to automate them with Macros (VBA) or Power Query.
Another level of automation can be achieved through formulas. Let’s have a look at some
formulas and shortcuts you can use to quickly clean your data.
 



Remove Empty Values
It may happen that some cells in your file have empty values, so you want to identify them fast
and decide what to do with them. You can hide them, remove them or replace the missing values
manually.
There are many ways to do it and we will see a few.
 

Technique 1
 

✂   SHORTCUT: Click CTRL + SHIFT + L to add filters
Click on Quantity > Filter Icon
Untick (Blanks) from the list
You will notice changes in the row numbers, as these rows are now hidden
You can repeat this process for any column you need to quickly see through your data set,
both with one or multiple filters selected at a time

 



 
Technique 2
 

✂   SHORTCUT: Click CTRL + SHIFT + L to add filters
Filter by Descending Order to group the empty values at the bottom of the data set

 

 
Technique 3
 

✂   SHORTCUT: Click CTRL + G to open Go to Panel > Click on Special
⏱   MANUAL: Ribbon > Home > Find & Select > Go to Special > select Blanks



 
 
 
All the blank cells are automatically selected. You can change the color to highlight them and
sort them by color, to add a visual element to the data set.
 

    
 
Once you identify the blank cells in your data set, you can decide how to manage them. You can
remove the entire rows, hide them or manually fill in the blanks.
 



Power Query
Power Query offers is an Excel automation tool to connect external databases, extract data and
process it. The result is an Excel table with the extracted data, which can be updated with a click.
With Power Query you can connect different data sources in the cloud in a unique worksheet,
you can extract, model, clean and analyse data and create automations. Power Query involves
some programming understanding and it’s generally time consuming. It’s an advanced tool that
will be explained in a dedicated book.



Excel formulas for professionals
We will now have a look at some new formulas you can use to clean your data. The advantage of
the formulas is that they are dynamic, therefore, if some cells change in the original data, the
results displayed in the formulas will change accordingly. Those formulas can be used to clean
the data and to carry out other tasks.
 
If Formula
The IF formula is one of the most important formulas in Excel, particularly useful when used on
large data sets. If a specific condition you set is verified in a cell, the destination cell will display
a value you decide. Let’s look at an example.
We are running 5 advertising campaigns in 5 different countries. We have a specific budget for
each country and we have updated the spend data so we can now verify how we are pacing.

We are now going to add a column with the formula. We will use the IF formula to compare
spend data with budget data and return information automatically based on the calculation.
We can type in E4 =IF(D4>C4,"Over Budget","OK")
If the value in D4 is greater than the value in C4 (and so the condition is met), the formula will
return the first parameter, “Over Budget”, otherwise the formula will return the second
parameter: “OK”.
You can change the values in cell A2 or B2 to see how the value in C2 will change accordingly.
You can write any condition you want in the first part of the formula, as long as it is a correct
formula, and decide what values to display if the condition is met or not. You can also write
more complex formulas in the first part and include more than 2 cells. If needed, you can then
flash-fill and create a new column in the table that will automatically update as the cells involved
in the formula will change values.
You have now the basics of this formula. We will not analyse all the possible scenarios where
you can use it (or this book would become 2,000 pages), but you have now enough knowledge to
know that IF formula is used to compare values and cells through formulas and return a specific
output whether the condition is verified or not.
 



 

 
Press Enter and drag the formula down

If we realize we made a mistake and we need to correct one parameter (e.g. Japan budget), we
just need to edit the cell and the IF formula will update automatically.

We can also combine this formula with Conditional Formatting to have instant visual insights as
we update the data. 
Ribbon > Home > Conditional Formatting > Highlight Cell Rules > Text that contains > type
“Over”
All the significant changes in Budget and Spend will reflect on the new column and the
formatting.
 



Mastering formulas and combining them with formatting is one of the most important skills you
can invest in, as it will allow you to work faster, smarter and more flexibly. Once you will be
able to leverage Excel automation, you will be able to get Excel doing most of the heavy-lifting
for you.
That’s personally one of the things I like the most: coming up with the fastest processes to make
every week’s work faster. And, I can tell you, I can go much faster than many. It all comes down
to planning, organization, understanding which tasks you will have to repeat every week, and
then find a way to automate them as much as possible.
 
 
Trim
The trim formula allows you to remove un-necessary spaces from a text string. For instance: in
this example the column with the customers names has a lot of spaces and we need to clean it.
 

Select an empty cell near customers names and write = Trim(
Select the cell you want to remove the spaces from and close the bracket
Press Enter
Drag down the formula

 



 
You can also use the formulas
 
Left, Mid, Right
Let’s add a new field to our data set: Customer ID

Select the cell you want to extract the characters from
=Left(cell, number of characters from the left you want to extract)
=Mid(cell, starting letter number, number of characters from you want to extract)
=Right(cell, number of characters from the right you want to extract)

 
Again, formulas are dynamic, so you can automatically manage any data changes dynamically
and use these formulas to remove unnecessary spaces.
 
Left
Type =Left(select cell, type the number of char from the left you want to extract)

Right
Type =Right(select cell, type the number of char from the right you want to extract)

 



Mid
Type =Mid(select cell, type the cell index where to start from(5), type the number of char to
extract(3))

 

Upper, Proper, Lower
Upper, Proper and Lower are easy formulas to automate data cleaning and fix text lettering
issues.
The syntax is very simple

=LOWER(text)
=UPPER(text)
=PROPER(text)
 

Let’s see an example. Let’s imagine that the previous table where we trimmed the customer
name comes in a bit different. Not only there is a lot of un-necessary spacing in the names, but
also the capitalisation is not correct. There is a mix of randomly capitalised and uncapitalised
letters and we want to be able to clean the data properly, fast, and flexibly. Most of all,
automatically.



As you can see, I edited the Customer Name column and the TRIM formulas got updated, by
removing the un-necessary spaces but leaving us with some formatting issues
 

Upper (all letters are capitalised)
Type =UPPER(select the cell you want to format)

Lower (all letters are uncapitalised)
Type =LOWER(select the cell you want to format) 

 
Proper (only initials are capitalised)
Type =PROPER(select the cell you want to format)



Proper is the best option in our case. It doesn’t matter how I will receive the data in the customer
name column, as long as I have trim and proper combined, I will be able to manage those types
of issues automatically and transform the data exactly as I want in auto-pilot

These functions can also be combined in the same formula, to save space and time. Combining
formulas is a very common activity in Excel, it requires a deeper understanding of Excel and
formulas.
But, as said, master the simple things and you will be able to create great automations.
Below is an example of how formulas can generally be combined.
In this example, if I know that my data will have those types of formatting issues, I can easily
create a formula with two nested functions to clean it automatically.

Concatenate
Now, let’s complicate the scenario a bit more and introduce some advanced tips.
Our focus will be the Customer Name Column. Let’s imagine that the people or the software that
collects and organize the data is struggling to send us a clean spreadsheet.
So, not only there are spacing and lettering issues, but names and surnames are in separate
columns.



You can use the function Concat to dynamically link the values from two different cells
Syntax =concat(text1, text2,…)

 
No matter how Name and Surname will change, the function Concat will combine them for me.
All you need to do now, is to apply the nested proper and trim functions to the concatenated cells

 
I know what you are thinking.
Can I combine these functions in the same formula?



The answer is Yes. As you can see, below we combined all the 3 functions. We can use this
automation to clean our data and set this up to automatically clean the data every week, when we
receive updates.
To stress a bit more on the importance of automations, bear in mind that you are not learning
these skills to use them on a dataset only once. As you will be working on a specific process, you
will more likely work on different data sources and you will receive updates on a weekly, daily
or hourly basis. This will require you to get familiar with the data source, set-up a cleaning
process / routine, setup tables and charts, and set-yourself up to spend the least amount of time
doing manually things that you can automate. This will require you to learn the process, and find
the best solution to make your life easier.
The order of the function is very important and it’s not uncommon to encounter errors when
trying to combine multiple functions or operators in the same formula. This is part of the process
and will require you to check brackets, columns, semi-columns and syntax.



Chapter 8: Excel Most Important Formulas & Functions
There are over 470 formulas in Excel Function Library.
As we have seen, formulas allow you to compute quick calculations, setup validation conditions,
automate the work, clean data and much more. We will now go through the most important
Excel formulas you need to know to consider yourself proficient in Excel.
These formulas will allow you to dramatically improve your skills, improve your chances of
landing a job that involves Excel and most of all massively speed up your data analytics process.
 
Goal Seek
Goal seek is a function that allows you to find a desired outcome value, by changing fields in
cells linked by formulas.
To better understand Goal seek, let’s imagine an example from a real work scenario. 
Department of Online Marketing. A client has just changed the budget for a campaign and you
are required to do some re-planning with the new budget and re-calculate the client fees.
A traditional business model in advertising is that the client pays a percentage of the money
spent on Facebook. Let’s assume 10%.
So, if the client spends €50,000/month and pays 10% on top of the advertising spend, the client
will give us €55,000 a month.  €50,000 to spend online and €5,000 as our fee. The problem is
that these are easy numbers and the client gives generally the total budget, so we need to deduct
the fees on top of the budget and calculate the money to spend online backwards. So, these are
the hypothesis and the scenario

 
 
So, I created a set of formulas through which I calculate the fees. Nevertheless, the formulas
would work if I edited the Advertising Spend, and not the budget.
I don’t want to change all my formulas now, so I will get Goal seek to set one cell to a desired
value, by changing another cell linked to it through a formula.



Below you can see the formulas I setup in my table.

 
To use the Goal seek function

Ribbon > Data > What-if Analysis

 
Click on Goal Seek

 
For this exercise, I want to setup the cells that contains the old budget to €28,523 by changing
the cells that contains €50,000, so I will be able to get the Facebook ad budget, whose 10%
added on top will be = to my final budget.



 
Let goal seek work…Et voila!
Now I know that I can spend €25,930 on Facebook, to which, a 10% added on top will
correspond the client total budget.

 
SumIF, CountIF, AverageIF
As you may get from the names, those formulas are a mix between IF and Sum, Count, Average.
We are going to start from a dataset and make one of the 3 based on a condition we will input in
the formula. We could spend a lot of times going through these formulas and all the possible
variations, but being proficient in Excel requires also that you are able to pick up new concepts a
bit faster, so now I will show you the formulas, practical examples and what are the formulas
doing. By this point, you should be able to understand it fairly easily, which means that your
skills are already improving. 
In this example, we have a series of products and units sold in different countries from different
sales reps. All I am interested in is understanding the total number of t-shirts sold. I am using the
formula SUMIF to check column D, where I have the product name and look for “T-shirt”, and if
the value is found, I will get the function to add up the correspondent unit values in column E.



 
The same applies for COUNTIF and AVERAGEIF functions.
If you don’t need those numbers in a table but you just want them for your own calculations, you
can simply

Add filters to the table
Sort the items by name so you can display them in order
Select the numbers you want to add up, count or average
Look in the Excel lower part of the interface, to see real time calculations

 



Vlookup
Vlookup is one of the most important formulas you need to master to consider yourself proficient
in Excel. Vlookup will allow you to find values within a dataset based on conditions.
To give you an example, let’s imagine you have a data set like the below. This one has 11 rows
and 4 columns, but it could be any size.

Syntax: =Vlookup(Cell you want to find, Range you want to analyse, Column Index, FALSE)
In this example, I want to find the column index 4 – REGION – within range B4:E11, and find
the value associated to Joseph, which is in B10. The formula will return “Japan”
FALSE is a syntax part of the formula that will search for an exact match.
 

 



Now check this.
Click on the cell to step in the formula
Click on B10 (joseph) and simply drag the cell outside in G10 – so the values you want
to find with the formula will now point to G10, outside the table

 
Now the Vlookup will search through the data range, but instead of looking for the value in B10,
which is in the table, it will search from the value in G10.
You can manually type in any name in G10, and the Vlookup will return the right region.
 
If I type Paul in G10, the Vlookup will show USA



If I type Rober in G10, the Vlookup will show France.

When you are managing large data sets, a Vlookup at the right place, is the way to see through
your data in a blink of an eye.
 
Let’s see another interesting example that can save you quite some in a lot of tricky situations.
We have created a Vlookup, we added a dynamic cell to it.
But we still have to manually type the name to let the function analyse the table.
What if we didn’t want to type the name every time?
Let’s create a drop-down list and let’s place it in G10, so we won’t have to type the names, we
will just have to select them from a list.
 

Create a list of unique names you want in a safe spot in the file (follow the image)
Select G10, the cell we want to change.
From the Ribbon > Data > Data Validation



 
 

Select List among the available options in the drop-down
 

 
Add the range with the list you just created to the Source box

 



Press Enter…et voila’! A beautiful fast dropdown list you can now select the values from
This type of process can be used for many purposes.
You can use Vlookup and dropdown lists in a variety of different ways, in combination with
other functions, or by themselves, depending on what you need to do. Those are the tools.

 
Let’s see now another interesting use for the Vlookup: let’s create a separate table, where we
categorize the countries by continent. How do we add this information (Continent) to our table,
and set it up so it can get updated in real time?
This example of Vlookup can be particularly useful when you have data (Country) and you want
to add extra fields automatically (Continent) because you need them regularly for your analysis,
but you are not receiving them in the original dataset. So, Vlookup will be used to linked the 2
tables.

 
You can do it by using the Vlookup function, you will select the range of the new auxiliary table,
and you will automatically associate the value in region to the column number 2 of the range
(continent)



 
Don’t forget to lock the range using absolute reference, otherwise as you drag the formula down,
you will also drag the range down, and this will result in errors. Simply add a $ before and after
each row and column in the cells that define the range
 

 
This way, you will have no formula when dragging down the formula.

The advantage of this is that, when you receive the new data, you can copy – paste it over the



old data, without touching the Vlookup formulas, and the values will be automatically
updated
 
Week 1 - data

 
Week 2 – data (copy – paste the new data over, Vlookup column updates, Auxiliary table doesn’t
change and it’s there to reference the range. You can update Auxiliary Table over time and
update the range in the Vlookup formula)

The most recent versions of Excel have also a formula named XLOOKUP.
 
The new XLOOKUP formula has the solutions to some of VLOOKUP's biggest limitations. It
also replaces HLOOKUP (used to search for a value in the top row of an array of values).
XLOOKUP can search to its left, the default is an exact match, and allows you to specify a range
of cells instead of a column number. XLOOKUP function is only available in Excel for, Excel
2021, Microsoft 365 and Excel for the web, you can upgrade your Excel to the available version
to get XLOOKUP.



 



Excel shortcuts & formulas to create massive automation
We will now go through a list of the most important formulas for professionals
To show current date and time in a cell. Select cell
✂   SHORTCUT (Today Date): CTRL + ;
✂   SHORTCUT (Current Time): CTRL + Shift + : 

To format cells with date and time format
✂   SHORTCUT (Date): CTRL + #
✂   SHORTCUT (Time): CTRL + Shift + : @

 
 
You can use the formula =Today() to display the current day in real time. Every time you will
open your Excel file, the cell with this formula will show you the current day.
You can create simple formulas that auto-update, such as the time period (days) from Today and
a specific date in the past. In the example below

Today will change every day
Start date can be changed manually
Time period will tell you every day how much time has passed since the start date
This will all happen automatically without you having to do anything else

 



               
Extract Day, Month, Year from a date
Imagine you receive a data set with a daily breakdown. How do you go from a date to its day,
month, year and add it to the table in seconds? Use the Text Function
 
��  Day =TEXT (cell reference, “dddd”)
��  Month =TEXT (cell reference, “mmmm”)
��  Year =TEXT (cell reference, “yyyy”)
 
In day and month, the number of letters you will type in the second part of the formula will
determine how many letters will be shown from the function.
In the example below we can see a dynamic table with

Today date in C5, it will change every day automatically
Text functions linked to D5 will update accordingly
You can start from this model to create your first calendar in Excel

 

Here we can see another example



 
This formula can also massively speed up your work when it comes to data analytics.
Imagine you receive a data set with a daily breakdown and you need to analyse it

You can use this function to add the day to any file in seconds when needed.
As for the previous example, if you copy-paste new data ensuring that column D points at
column C, you will be able to retrieve the day of the week from your data set. Then, using the
techniques we have covered, you can do a day of the week analysis to see if you notice patterns
(filters, slicers, charts)
 



    
 
Freeze Panes
What does “Freezing Panes” in Excel means?
It’s very simple: if you have a big range of data and you want to scroll through it by maintaining
specific rows and columns always visible… you are about to learn how to do it.
 

Select a cell and click it. In this example we will select cell B4 (Jim)
Ribbon > View > Freeze Panes

 

This will freeze every cell above B4 and every cell on B4 left
 



 
This is particularly useful when you have large datasets and you want to scroll up-down and left-
right without losing sight of your data
 

 
Click on view to restore the instruction and unfreeze everything. You can also decide to free the
top row only or the first column only

 



Concatenate Text and Numbers
We have previously learnt how to concatenate two cells with text. Now we want to concatenate a
cell with a string value and a cell with a numerical value.
This formula may look complex at first. The key to understand it is the following
 

Put the text between " "
Put the cells references between & &

 
This is going to be the starting table

 
Checkout the formula.
The cells references are between & &, while the text is in between “ “ 
The goal is to incorporate dynamic cell values with static text, and automate the commentary

Press Enter to confirm. You just created a concatenated text



 
Drag your formula down

 
Replace data in the data set via copy-paste and the comment will auto-update



 
Add comments
To  add comments in Excel. S elect the cell you want to comment
✂   SHORTCUT: SHIFT + F

Hover over to display the popup with the comment
T o delete: Right Click > Delete Comment
 
 
Insert Hyperlink
This Excel shortcuts will allow you to embed a URL into a cell value and make it clickable.
In this example, we will add our Tutorial playlist from our Youtube Channel and paste the URL
https://www.youtube.com/channel/UC_CgkwIL3XdKVNFJBgm6lcg/playlists
to the cell with the text Link >>
 
✂   SHORTCUT: CTRL+ K
Type in the URL or paste it if you have previously copied it
 

https://www.youtube.com/channel/UC_CgkwIL3XdKVNFJBgm6lcg/playlists


Click OK.  

Your cell is now a clickable link. You can click it to be redirected to the link, or edit the link by
selecting the cell and pressing again CTRL + K. A useful command that will allow you to keep
everything in the same place, in case you need it.
 
Paste Special
When you copy-paste / cut – paste data, you may notice a small notepad icon in the bottom right
corner of the data set you have pasted. When you click it, an option panel will open and you will
be able to tell excel how you want your data to be pasted.
We will cover here only the main options, as the way it works is pretty intuitive and, when you
paste data, you just have to hover over the different options to see data changes in real time
 
Transpose
In Excel, Transpose means changing rows into columns and vice versa.



Let’s see an example.
Imagine you a column like this and you want to convert it into a row
Simply copy-paste your data, click on the icon and select Transpose

 
And you can easily switch from row to column and vice versa.



 
Index + Match
Index match is a way to perform advanced lookup. It allows to do different types of lookups very
fast and flexibly. Let’s start with Index. The formula will return Robert, which is at index 4 in
the selected range)
 

Now, I want to understand what product Robert has bought. I will use the same function but I
will extend the selection to the entire table, and in the second part of the formula, I will add rows
and columns index)
 



 

Match
The Match function allows to insert a value belonging to a data set and get the index in return
In this example, the function returns 5, which is the row index of Arnold, in the Range (B6:B16)
0 is added for the exact match.
 

 
Match can also be used horizontally



 

We can combine Index and Match together.
Index and Match
First, let’s start with Index. Just to recap, I select the data range, the row number and the column
number. The following function will return Japan (Row 6, Column 4)
 

 
Press Enter to confirm

 



Let’s take the formula one step further and let’s replace the row number in Index (6) with a
Match expression. We want to Match the name Joseph within the array B4:B14 and find an exact
match. As you may notice, the column number for the Index function at the end of the expression
hasn’t changed.

 
Press Enter to confirm. We have now the same result as before, but now we made the formula
more flexible.

Let’s take it one step further and let’s replace “Joseph” by linking that part of the formula to
G10, an empty cell that we will fill in manually

 
 



As you can see when we press Enter, we see an error message. This is because for now the cell is
empty so Index and Match can’t find that value within the ranges they operate.

As we change the value in G10, the result of Index Match changes in real time.
With this simple strategy, you can search through database in real time, input a parameter and
find the information you are interested in with one click.
 

 
In case you want to change the ranges, simply click on the formula, then click on the ranges
borders or corners to move them or resize them as you need.



 



Chapter 9: Uses of Microsoft Excel
 



What can you do with Excel?
A quick list of tasks that can be practically done with Excel at the workplace, you should now
start seeing many of these more clearly.
 

1. Data Entry and storage
2. Collection and verification of business data
3. Administrative and managerial duties
4. Accounting and budgeting
5. Data analysis
6. Reporting and data visualisation
7. Forecasting
8. Managing product information
9. Stock and inventory management
10.                    Business task automation
11.                    Compiling, managing and mailing contact lists
12.                    Checklists, time-logs, to-do lists
13.                    CRM creation and management
14.                    Calendars and schedules
15.                    Goal planning
16.                    Mock-ups
17.                    Project Management charts
18.                    Forms

 



Templates
What are Excel Templates?
Templates are pre-made spreadsheets with formulas and charts you can open and customise to
your needs. You can use template for multiple purposes.
Click on File > New from Template
A window with the templates will pop up. Scroll through the templates and double click to open.
 

 
 
You can open a beautiful Personal Budget Template with tables and charts. You can customise
the template as you need and personalise it, change formulas, add or remove items
Before start working, Save the File as New. You will essentially duplicate the document and
save it with a new name.  This is because you want to keep track of all your changes and work
with structure.
Save the file as new every time you need to make a copy.
 
✂   SHORTCUT: CTRL + S 
⏱   MANUAL: Click on File > Save as New
 
Name the file, select where to save it and confirm.



 
You can select a very useful Family Budget Template. The idea is creating a spreadsheet you can
keep updated every month and keep track of your income and expenses in real time
 

 
You can use the list templates if you simply need to make a list or calculate expenses on a
separate file or a separate sheet. Millions of people in the world use Excel on a day-to-day basis
as a task organisation tool.
 



   

 



You can use the Budget Template and customise it in no time.
Remove rows, columns, cell, update formula ranges by stepping in cell formulas and drag
ranges or change them from the formula bar.
 

 
If you work in sales or online sales, you can check out the Online Sales Tracker Template, where
you can connect spend data and sales data from different data sources and use Excel to create
data connections.
 



Excel is also widely use to do Financial Reports. You can use this template, study it, get inspired,
notice how being able to create client friendly dashboards is actually a big part of the data
analytics process.
Not only you have to be able to clean, organize and analyse data, but also putting attention on the
delivery, and aesthetics is a big part of the picture, often bigger than you may realise.
Notice how you can organize the most important information and lay them out in a clear, concise
way.
The below is a mix of text, tables, charts, potentially linked to an interactive dashboard in
another sheet where you have done all your main calculations, formulas, charts, and now you are
just displaying them in a beautiful, clean client report.

 
✏   NOTE: In case you are wondering: those lines are called SPARKLINES, and allow you to
create a small chart in a cell. We didn’t cover them as they would pertain to a course specific to
charts and reporting.
 

 
You can use Templates for credit card payoff calculations, assignment schedules, daily
schedules, calendars, budgeting, planning, inventory, workout log, invoicing, expense tracking



and more.
You can create your own template and use it to store information as a CRM database.
You can also download templates online, but always make sure you trust the source.



Chapter 11: How to Take Excel Charts to the Next Level
 
After all these years working with Excel and Business Intelligence software, we asked ourself a
question:
Why does creating beautiful charts have to take so long?
A few years back, I was working in social media advertising with my business partner, Paolo.
We were managing budgets in the millions for the biggest brands on the planet. We were
spending a lot of time doing the same tasks over and over, wasting a lot of time in formatting
activities, creating tables and charts and spending a big portion of the time to automate them and
make them client friendly. Over the years, we have tried different solutions, created our own
automation with Visual Basic, Power Query, Power BI…but no matter how hard we tried to
automate our process, we often ended up doing a lot of manual work, which would put us under
pressure, given the high number of clients, campaigns and platforms.
So, one day, we came up with a solution.
What if we could do all of this, in just under 5 minutes a week?
That day, we created Reporting King.
Reporting King is a software to transform a raw data file in Excel into a beautiful
interactive dashboard and a client report in minutes.
 
Reporting King is designed to achieve a lot, in a short time, the easiest way possible.
As you trusted us when purchasing this book, we want to reward you with a FREE trial, where
you will be able to use all the Reporting King features for absolutely FREE. And, as one of our
readers, you will be able to get an EXCLUSIVE EXTRA 20% OFF FOR THE FIRST 2
MONTHS should you decide to pay for Reporting King after trying it for FREE.
The FREE trial has no obligations, you are welcome to continue using it or simply write us an
email to give us feedback and help us improve the product. As you may have understood by
now, our goal is to share our knowledge and experience so we can empower people solving
problems when it comes to Excel and analytics. Videos, step-by-step guides and books are only a
piece of the puzzle. We love to create real process automation through technology, and we want
to share it with the world so anyone can analyse data and making beautiful presentations, no
matter the skill level.
You can check the full Reporting King by scanning the QR code.
Reporting King is simple, easy to use, fast, and will save you countless hours of energy and
stress.
Check out how this works.



 
 



Try Reporting King for FREE and take your charts to the next
level

Get an Exclusive 20% OFF discount for READERS
 
For more information, visit our website at www.reportingking.com
 
Watch a 1-minute video tutorial, to see the REAL POWER OF AUTOMATION IN ACTION

 
Reporting King
Video Tutorial

 
Find us online
��  Website: www.reportingking.com
��  Desktop App: app.reportingking.com
 
Follow us for on our social media channels for Excel tips, tricks & shortcuts
Facebook: @reportingking
Instagram: @reportingkingapp
Tik Tok: @reportingking
LinkedIn: @reportingking
Twitter: @reporting_king
YouTube: @reportingking

https://www.reportingking.com/
http://www.reportingking.com
http://app.reportingking.com/
https://www.facebook.com/ReportingKing
https://www.instagram.com/reportingkingapp/
https://www.tiktok.com/@reportingking
https://www.linkedin.com/company/reportingking
https://twitter.com/reporting_king
https://www.youtube.com/watch?v=ifqSVVkIRLU&list=PLBcW4GYRQ00ys8iJ9BT17GBeZyMfGxZY-&ab_channel=ReportingKing


 
 



Conclusion
Thank you for reading this book, I hope you enjoyed it and, most of all, I hope you learnt a lot of
new things! What I wanted to transmit you was not only formulas and functions and how-to, but
also process, lateral thinking, creativity, problem solving.
I encourage to keep studying, keep upgrading your knowledge and use Excel to consolidate the
learnings.
Whatever stage of your life and career you are at, define your goals (personal, professional),
understand how Excel can help you reach them, and deepen your Excel knowledge specifically
in that niche.
(What does this job entail? What do I know about Excel to be successful at this?)
Whether you want to use it for personal reason, work remotely and monetize your skills, or boost
your job prospects, you have already finished an intensive manual with you tools, tricks,
functions, tutorials, workarounds, shortcuts, hacks... and you are already ahead in the game!
The world if full of opportunities and Excel can definitely provide some for you, as it’s already
doing for hundreds of people all over the world.
I wish you luck, success, and continuous learning.
Remember: you didn’t get this far, only to get this far. The sky is the limit!
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